I just received my opensprinkler, and am looking forward to getting it setup with this great looking web app!

The standard web interface is up and running, accessible from the public internet via port 80.

I have a hosting provider where I’ve uploaded latest available release of the web app, and get to the installer page.

Issue 1: When I click ‘Submit’ on the installer page

The apache error log shows:
[/usr/local/apache/logs] $ tail -f error_log
[Sun Aug 11 18:38:19 2013] [error] [client ] PHP Warning: file_get_contents( [function.file-get-contents]: failed to open stream: Connection refused in /home//public_html/sprinklers/install.php on line 99, referer: http://www.
[Sun Aug 11 18:38:19 2013] [error] [client ] PHP Warning: set_time_limit() has been disabled for security reasons in /home//public_html/sprinklers/main.php on line 13, referer: http://www.
Are there any work arounds for this if the hosting provider is unwilling to make a change?

Issue 2: My hosting provider prevents access of directories that are set to 777, thus I can’t get to the installer page when permissions are wide open. I believe I read on the first page of this thread that it needs to be 777 to allow creation of directories or files. Can you please confirm this, and let me know if there is a workaround for my situation?

Thanks in advance!