OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Using MQTT to log data Reply To: Using MQTT to log data




I am not familiar with that part of the system which is the basic web templating part. However it looks like it is trying to load the home page and getting confused when listing the stations. I assume from your earlier posts you have more than 1 board ie more than 8 stations so it could be part of the multiboard logic, (which I dont use).

Although you have that error you can access other web pages. So do a sudo service ospi stop, then deactivate all plugins (mobile_app, monthly_app, relay, weather_adj, weather_level_adj. To do this go to the plugins directory and do a sudo chmod -x etc.

Then restart ospi with sudo python from the /home/pi/OSPi directory and try to load the home page. If it was one of the plugins causing it (I doubt it – but it is good to remove as many variables as possible) the problem should have disappeared.

If you still have the internal server error, you can still load other pages, so load http://ospi ip address:8080/vo   where ospi ip address is whatever IP address your OSPI system has.

You should see the options page. Click on the Stations handling option and check your system is configured properly, especially that the number of extension boards is correct. You could also set this to 0 as this should work.

If this checks out then try http:// ospi ip address:8080/vs and see if you get the right number of stations displayed.

Let me know how you get on. I suspect that there is somehow an inconsistency in these options introduced when you installed the different versions.