More details!

Saw the reference to a log file, here it is:

====== Fri May 8 10:44:12 2015 ======

avrdude: AVR device initialized and ready to accept instructions

avrdude: Device signature = 0x1e960a

avrdude: Expected signature for ATMEGA644 is 1E 96 09

avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed

To disable this feature, specify the -D option.

avrdude: erasing chip

avrdude: reading input file “./Firmwares/OpenSprinkler_v2.2/firmware2.1.4.hex”

avrdude: input file ./Firmwares/OpenSprinkler_v2.2/firmware2.1.4.hex auto detected as invalid format

avrdude: invalid input file format: -1

avrdude: write to file ‘./Firmwares/OpenSprinkler_v2.2/firmware2.1.4.hex’ failed

avrdude done.  Thank you.

====== Fri May 8 10:44:12 2015 ======
Error uploading firmware.


Since it was giving “invalid file format” for 2.1.4 I tried uploading 2.1.3 and it worked!  So, doesn’t look like there’s any kind of power/assembly issue at this point, more of a software issue.  Assuming no further issues someone might want to move this to the firmware forum.