OpenSprinkler Forums OpenSprinkler Unified Firmware changing port Reply To: changing port



The problem I had with port forwarding was because my tp link router reserves port 80 for router access.I changed the open sprinkler port per your instructions and works fine now.
This comment I made on the dead simple driver installation post.
0pen sprinkler v2.1 orange plug can’t update firmware followed directions exactly.Did every thing 3or 4 times ,zadig says driver updater,Download firmware says success.hold b2 plugin, nothing changes,window popup[no driver] from drop down ver.2.1[sticker on back] fails. why? thanks richard ====== Fri Jun 12 10:44:03 2015 ====== avrdude: error: could not find USB device “USBasp” with vid=0x16c0 pid=0x5dc. Tried three different cables.Running pc windows 7 64bi.

you replied
“hold b2 plugin, nothing changes” -> can you explain what you mean ‘nothing changes’? As per the instructions, the LCD should remain off. If the LCD lights up, that means the controller didn’t enter bootloader successfully and you need to repeat the bootloading process.
my reply

Aloha thanks for reply.LCD remained off. The problem was the zadig install.I did not know that the unit needed to be pluged in and recognized by the zadig installer before installing the driver.[?is that correct?].The firmware updated properly and only encountered some minor mistakes after restoring from internal memory.Now I’m trying to update an older unit[green power plug [firmware 2.1.2,hardware v2.0]]windows does’t recognize and gives an error message,shows up as an unknown decieve.Plug unit in, lcd shows home screen but zadig popup shows no device in the scroll down.In the options on the zadig window shows up as unknown device.Select that and select usbwin32,run and get error message unknown device.Try the os updater but only fails.This is a unit I had previously sent to you for repair.Tried the unit connected to router and all seems to be working fine.Also tried everything as administrator.I also downloaded the driver from adifruit but nothing shows up.What am I missing? thanks richard