Been trying to isolate what setting might do this. My first thought was dom.storage.enabled. Nope, that’s set to the default of true.

If found this post:


Which says:

“disabling cookies disables storage, unless the site is on the whitelist

if the cookie preferences are set to prompt, this is treated the same as reject cookies”

I have my Firefox cookie preferences set to “Accept cookies from 3rd party sites, keep until ‘ask me every time'”. I changed that to until ‘I close firefox’. and it starts working.

So… Preferences -> Privacy -> Exceptions… -> In the “Address of website:” box, add my OSPi address and click “Allow” to always accept cookies from OSPi, which apparently also allows offline storage. Type in my OSPi URL and – It works!