OpenSprinkler Forums OpenSprinkler Unified Firmware Issues with weather data Reply To: Issues with weather data



Hi dun4cheap,

Thanks for your reply. I had previously read your posts as I was researching the issue. I feel as if I have tried so many different things, resetting to factory defaults and trying to simply just get the weather data to pull. Unfortunately nothing has worked. I’ve tried setting my location with the map by locating my weather station and also by just selecting a random nearby non pws point, still nothing. It gets my location name correct but the timezone is wrong and the weather data never get as last successful call date. I did find a way to get my timezone correct, I had to wipe my location so it was empty and then the UI let me manually adjust my timezone. So I set my timezone correctly and then saved my changes. Now it keeps my time zone correct but I still can’t seem to get the weather data to pull successfully.

So to try what I believe you are suggesting I have remove my location altogether. I verify that it is empty in the JSON config and then set my location again. I then verify that my location is set to the desired weather station, “loc”:”pws:KAZTUCSO435″. However it still does not work. I have also tried rebooting between these changes as sometimes the location in the UI does not show that it changed. I then try to set my location to a non pws, just lat/long coords “loc”:”32.26273,-110.73243″. I get the same results, I can see weather data for my location on the main UI page and when I run the weather diagnostics I get accurate information for my location, however still not last successful call.

Although I don’t know if any technical logging occurs for wunderground api calls, I do believe it is working. My key is correct and when its entered I see all the weather stations on the map, which doesn’t happen if I don’t have a key installed. I also see accurate data in the diagnostics and the main screen, all implying to my assuming eyes that the api is working and returning data. Why the system does not record a last successful call is still beyond me.

Let me know if you think I didn’t try what you suggested correctly.