OpenSprinkler Forums OpenSprinkler Unified Firmware Update to latest firmware doesn't work [SOLVED – See solution in thread] Reply To: Update to latest firmware doesn't work [SOLVED – See solution in thread]



Update 25th Nov: tried several times, update failed.
Update 18th Nov: tried again, update failed.
Tried to update firmware 7th Nov 18, several attempts tonight.
Exact same result as OP; jeffhaas

Opensprinkler Controller:
App Version: 1.8.2
Firmware: 2.1.7(1)
Hardware Version: 3.0 – AC

PC / Browser(s):
macOS Mojave 10.14
Chrome – Version 70.0.3538.77 (Official Build) (64-bit)
Also Safari – Version 12.0 (14606.


Typed in http://#.#.#.#/update failed,
Clicked ‘bell’ notification and selected ‘update’, failed
Used web interface to change password and log in again, just to be sure.
Rebooted Controller.
Tried http://#.#.#.#/update again, failed
Typed this post and tried again, failed.
Will try again tomorrow.

Controller works a treat, still need to fine tune Zimmerman parameters, doesn’t water enough in cold weather (-4C -> 15C)
Looking forward to using Evapotranspiration, local feed here:
Would only need to download once a day at 1am.
More data here:

Hoping firmware update will fix a few glitches with log display failing when more than 2 days selected:
Log retrieval takes a long time or fails, hopefully new release increasing log space from 1MB to 3MB helps.
Not sure why the log file on 7 stations would ever exceed 1MB over 7 days.
Local time shown correct in app but red line in preview lags a couple of hours.