OpenSprinkler Forums OpenSprinkler Unified Firmware Can't change a Station Name. Reply To: Can't change a Station Name.



Replying to this thread to share that I encountered the same issue with regards to not being able to rename stations. The explicit factory reset resolved all of my issues and I made sure to copy down all information before doing it (was afraid a restore would have the same issues).

A few other notes I wanted to share in case you’re seeing this and it looks familiar. Also to save you some time on troubleshooting:
I had other weird things like renaming a station would rename other stations. Mostly seemed to happen for station numbers below the station I was renaming. For instance, renaming Station 6 would rename 7 and 8 as well, but not 1-5.
Tried the “Reset All Station Data” option and it just showed “reset” for most stations after it was done, but still the same issue with trying to rename them after.
Tried restoring from a backup file I had and still had the same issues. I did NOT try to restore from the backup after the factory reset. The backup file may have worked in this case, but I didn’t want to take the chance that the backup would have the same problems. To be honest, it would probably have been fine because it’s just a JSON file with values.

The main takeaway is that the factory reset will usually fix all issues and it’s not that hard to do as long as you copy everything down first. Hope this helps!