OpenSprinkler Forums OpenSprinkler Unified Firmware First version of firmware 2.2.0 ready for testing Reply To: First version of firmware 2.2.0 ready for testing



Updated my OS 3.2 – DC to FW version 2.2.0(1) today from 2.1.9(11). It is winter here so there is no critical operation issue. I am starting the process of updating my app to the new API and testing in prep for spring.
The process to update FW and get back to my original config did not do as expected. Here’s the detail:
The FW update worked as expected. I then followed the instructions for a new install: connected to the OS in AP mode via a PC, pointed the browser to, selected the SSID and provided the appropriate WIFI password. The status on the LCD said connecting… but it didn’t complete or reboot. I normally run with an Ethernet adapter so I reconnected the adapter and rebooted the OS. I then pointed the browser at the normal OS IP and connected. Success. I then tried to import the config which failed with: ‘Unable to import configuration.’

Everything else seems OK. I could change the password. Run System Diagnostics with expected output. Ran a JSON command that worked in 2.1.9. It worked as expected with new 2.2.0 output.

Did I do something wrong? Does the new FW have trouble with some parts of an old configuration file?

Thanks, Dave