OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Interval 2 program issues Re: Re: Interval 2 program issues



I get the same “internal server error” response when I click on the Programs button of the webpage. I’m adding my voice to the previous messages because I haven’t installed any plugins or supplementary applications on the Pi; the OSPi is nearly virginal, just out of the box (so to speak) with only the usual setup that was necessary to try it out. Software version is 2.0.1.

After striking out with the web interface, I installed the Windows Phone 8 app and was able to set up a rudimentary program using that app but I’m still learning how to get everything the way I need it.

Please let me know if you need me to try someting else to help isolate this bug.


UPDATE (see below the log file).

pi@ospi ~/OSPi $ sudo python
The Python module apscheduler could not be found.
Setting water level to 100%
plugins loaded:

Starting timing loop – – [04/Jul/2014 14:11:24] “HTTP/1.1 GET /” – 303 See Other – – [04/Jul/2014 14:11:24] “HTTP/1.1 GET /login” – 200 OK – – [04/Jul/2014 14:11:25] “HTTP/1.1 GET /static/images/favicon.ico” – 304 Not Modified – – [04/Jul/2014 14:12:11] “HTTP/1.1 POST /login” – 303 See Other – – [04/Jul/2014 14:12:14] “HTTP/1.1 GET /” – 200 OK – – [04/Jul/2014 14:12:15] “HTTP/1.1 GET /static/scripts/jquery-1.8.2.min.js” – 304 Not Modified – – [04/Jul/2014 14:12:15] “HTTP/1.1 GET /api/log” – 200 OK – – [04/Jul/2014 14:12:15] “HTTP/1.1 GET /api/status” – 200 OK – – [04/Jul/2014 14:12:15] “HTTP/1.1 GET /api/log” – 200 OK – – [04/Jul/2014 14:12:45] “HTTP/1.1 GET /api/status” – 200 OK – – [04/Jul/2014 14:12:45] “HTTP/1.1 GET /api/log” – 200 OK
Traceback (most recent call last):
File “/home/pi/OSPi/web/”, line 239, in process
return self.handle()
File “/home/pi/OSPi/web/”, line 230, in handle
return self._delegate(fn, self.fvars, args)
File “/home/pi/OSPi/web/”, line 420, in _delegate
return handle_class(cls)
File “/home/pi/OSPi/web/”, line 396, in handle_class
return tocall(*args)
File “”, line 814, in GET
return render.programs()
File “/home/pi/OSPi/web/”, line 881, in __call__
return BaseTemplate.__call__(self, *a, **kw)
File “/home/pi/OSPi/web/”, line 808, in __call__
return self.t(*a, **kw)
File “templates/programs.html”, line 177, in __template__

TypeError: unsupported operand type(s) for >>: ‘float’ and ‘int’ – – [04/Jul/2014 14:13:03] “HTTP/1.1 GET /vp” – 500 Internal Server Error

UPDATE: Perhaps this will be helpful to some: I was playing around with the web interface some more and changed the time zone offset to -7:00 under Options/System. Apparently, I hadn’t initialized it within the Interval program UI until then. Shortly after that, I tried the Programs button again, and it worked without error, even though I hadn’t rebooted after the time zone change. I even changed the Time zone back to 0 to see if the error recurred but, so far, I can’t make it fail again. Perhaps the bug has something to do with a time or date mismatch someplace that was fixed by me setting the Time zone. All I know is that it’s working fine for me, now.