OpenSprinkler Forums OpenSprinkler Unified Firmware long timer setting for Pool pump Re: Re: long timer setting for Pool pump



OK, I think I found a potential solution to the issue. First of all, the 1 second delay is because the program only checks and performs bookkeeping of running time once every second. This is to give sufficient time share to the Ethernet controller in order to improve response time to web requests. Therefore, after a schedule is finished, the program goes back to the beginning of the loop (where it checks web requests), and does not perform scheduling until a new second comes. So the quick fix is that after a schedule is finished, let the program re-do schedule checking before going back to the beginning of the loop, and this should solve the problem.

Specifically, you need to add the following two lines in inverval_program.pde:
1. Before the comment // ====== Schedule program data ====== and after svc.rainsensor_status();, add a label, such as:
// ====== Schedule program data ======

2. Locate code “mas = svc.options[OPTION_MASTER_STATION].value;” around line 307, and add the following line after that:

Basically this directs the program to go back to schedule check after a previous program is finished, and it should eliminate the 1 second delay.

Note that this only works when sequential option is turned on. If you want to run the controller in parallel mode, there is an additional change you should make. Also, keep in mind that this has not been tested thoroughly, it’s a rather ad hoc solution. Give it a try and see if it works.