OpenSprinkler Forums Hardware Questions Router Causes clock to jump back Re: Re: Router Causes clock to jump back



I have two OS’s still not working well. I have four units total; two are working well, two are not. All DIY kits.

Troubleshooting OS #1 (Using a single program to run 4 stations for 10 seconds sequentially). Without being connected to a router, it kept good time both with w/NTP “ON” and “OFF”. When connected to a non-internet connected router (with NTP “OFF”), it started sporadic time-keeping (seconds sporadic, but overall kept within a minute of the right time). 10 second station times became 26 seconds long and station indicators on LCD screen moved very slowly. The clock self-corrected after hanging on a minute too long, then jumped ahead to correct time. As a result, the remaining stations did not turn on (program ended). This occurred with NTP “ON” as well. When I connected back to an internet-connected LAN, all worked with NTP “ON” and “OFF”. I unplugged it entirely for a couple hours and it had the correct time when I plugged it back in.

Troubleshooting OS #2: (Same program: Single program to run 4 stations for 10 seconds sequentially). It seemed to work fine w/NTP “ON” and connected to internet-connected router. It auto-corrected the time when I plugged it in. I unconnected the LAN cable. It kept good time with NTP still “ON”. I turned NTP “OFF” and it took a long time to get past “connecting”. Oddly it still showed three bars (strong signal strength) with no “x” while unconnected. It seemed to work fine otherwise. I connecting to a router w/o internet connection (NTP still “OFF”), and the clock immediately stalled and cycled between 1815 and 1814. I turned NTP “ON” and reset. It took time “connecting” again and the clock was still stalled, cycling between 1815 and 1814. I disconnected the non-internet router and the OS stayed stalled between 1815 and 1814. I plugged back in to the internet-connected router, (NTP “OFF”) and there was no change in the clock, but it “connected” very fast. I turned NTP “ON” and reset, and it synced up to correct time. It lost several minutes over the next couple hours (NTP “ON” and connected to internet-connected LAN) and when I reset in (OFF-ON) in re-synced to the correct time. I left it “OFF” for the night and when I turned it on it showed the correct time right away; before going through the connecting routine. It lost time again what left “ON” and again when connected to internet-LAN ( a few minutes each hour)
Hope this isn’t too much detail… Thank you Ray.