OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Secure internet access to OSPi Re: Re: Secure internet access to OSPi



Hey, I’m trying to get the SSL proxy working with the Apache webserver installed. I’ve enabled the proxy modules but am having a problem with the proxy not replacing the references to localhost:8080 as I think it should be. I added a couple lines to try and get it to do so but no joy. Can someone take a gander at this Apache config and tell me if there’s something that jumps out at you? Here is the config:

ServerName opensprinkler
ProxyRequests Off
ProxyVia Off

Order deny,allow
Allow from all

ProxyHTMLExtended On
ProxyHTMLURLMap http://localhost:8080 /
ProxyPass / http://localhost:8080/
ProxyPassReverse / http://localhost:8080/

Order allow,deny
Allow from all
# AuthName "Access Restricted"
# AuthType Basic
# AuthUserFile "/etc/apache2/.htpasswd"
# Require valid-user

# Alias /mobile /var/www/sprinklers
# LogLevel debug
ProxyHTMLLogVerbose On
LogLevel warn
CustomLog /var/log/apache2/access.log combined
ErrorLog /var/log/apache2/error.log
SSLEngine on
SSLCertificateFile /etc/apache2/server.crt
SSLCertificateKeyFile /etc/apache2/server.key
SSLProtocol -ALL +SSLv3 +TLSv1

Here is what the browser is seeing with the view source option in Chrome:

var baseurl="http://localhost:8080"
var ver=183,devt=1402508212;
var sd = {
nbrd : 1,
tz : 24,
en : 1,
rd : 0,
mm : 0,
rdst : 0,
mas : 0,
urs : 0,
rs : 0,
wl : 100,
ipas : 0,
nopts : 13,
loc : '83704',
name : '4088 Armstrong',
ir : [0]

var sbits=[0,0],ps=0,0],[0,0],[0,0],[0,0],[0,0],[0,0],[0,0],[0,0;
var lrun=[0,99,86,1402506772];
var snames=;
var tempunit="C";
var cputemp=60.5; var tempunit="C";

As you can see, I think the problem is that the HTML script tags still have the http://localhost:8080 when that should have been replaced with something like “/”

Any thoughts would be appreciated.