This topic contains 18 replies, has 0 voices, and was last updated by  Ray 6 years ago.

Viewing 5 posts - 16 through 20 (of 20 total)
  • Author
    Posts
  • #23622

    Ray
    Keymaster

    As described in the user manual, if you change the time zone, you should restart the controller to get the new time. This is because every time you restart the controller, it will perform an NTP sync immediately using the time zone in your settings. Now, if you don’t restart the controller, eventually it will still get the new time because the NTP sync is performed every 24 hours by default.

    #23623

    gregas
    Member

    I’m having similar issues. I’ve set it to GMT-8 and the time is still wrong. I’ve rebooted and power-cycled both open sprinkler and my gateway router. I’ve also verified that computers on the same network and see an NTP server. Not sure what to try next.

    #23624

    Ray
    Keymaster

    First, make sure on the homepage you see GMT-8. If not, that means your time zone change is not correctly saved.

    If that’s correct, then it might be that your router is blocking the NTP sync port 123 for some reason. OpenSprinkler uses the NTP server at 204.9.54.119 by default. If you have a linux machine, try to run the following command:
    nmap -p 123 -sT 204.9.54.119
    and see if it reports the port is open. If not, you may have to change corresponding settings on your router to see if you can unblock the port.

    #23625

    gregas
    Member

    Thanks, Ray. I just found the issue…bad gateway config. I’m not sure why I did not think of that. It works now.

    It looks like there is no daylight saving time adjustment…is that true? Not a big problem…just want to know.

    G

    #23626

    Ray
    Keymaster

    You are right, the firmware currently does not automatically detect DST yet, so you need to manually change the time zone. This shouldn’t be too hard to add, and I will try to get this feature included in future firmware update.

Viewing 5 posts - 16 through 20 (of 20 total)

You must be logged in to reply to this topic.