OpenSprinkler Forums OpenSprinkler Mobile and Web App Android app v2.20 – what happened?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #66877

    dhmsjs
    Participant

    Apologies in advance for my ignorance.

    Long time OS user – I’ve got 4 OSPIs operating in the field for years now — all working fine. I can access them by browser just fine (just confirmed). Generally I use the mobile app instead.

    Android app has worked fine — tap on the icon, up comes the last site I was looking at. Hit Manage Sites and I can switch to another. Simple, clean, reliable. Love it!

    Today I run the app for a quick check of some new drip lines and…what the heck? No site info! Instead I’ve got a new screen that lets me go to OpenSprinker,com, log in to my “account” (I didn’t have one — but do now of course), search for my controller (which I don’t need to do) or manually configure a new controller (which I also don’t need to do).

    Guys, I just wanted to turn on a valve for 2 minutes or so! Instead, now I’m totally dead in the water. This app is now essentially useless to me.

    No matter how hard I try, I can’t get to the app configuration I’ve had for years. Seems like it’s gone for good. And replaced by something that’s forcing me to do all sorts of things I have no interest in doing. WHAT HAPPENED?

    Digging a bit deeper, it appears the app is now v2.20. Maybe recently updated, automatically? Looks like something might have been pushed out June 11?

    Shoot — sure wish I would have had some warning. Oh well, maybe I can downgrade. So I go looking for next most recent version. Nowhere to be found. I go to Github. “Newest” version there seems to be 1.8.0 — posted July 23, 2018. Hmmm.

    Seems like I’m missing something pretty basic here. Seems like there should be many others like me in a similar situation. But the oracle Google is coming up empty-handed.

    Anyone out there able to help this poor soul find his way back to OpenSprinkler mobile app home? TIA

    • This topic was modified 1 week, 6 days ago by dhmsjs.
    #66947

    dhmsjs
    Participant

    Follow up for those who might find themselves in a similar situation:

    It appears to me that the configuration files from previous versions of the app are not compatible with the new v2.20. I had to manually reenter the station name and ip address:port for each of my stations, but now we’re back to familiar territory. Not too bad; as long as you have that information easily available. 😉

    I might have been able to import the configuration from an earlier version’s exported config but I didn’t try. It ended up being easier to re-enter each station’s name & ip address than to find that old config file and then drag-n-drop it into the app’s Import dialog.

    Maybe someone else can confirm whether or not their pre-v2.20 config file will import into v2.20.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Mobile and Web App Android app v2.20 – what happened?