OpenSprinkler Forums OpenSprinkler Unified Firmware Announcing the official OpenSprinkler Firmware 2.1.0

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
  • #34203


    This is to announce that the OpenSprinkler Firmware 2.1.0 is now officially released. Since the beta version was posted a month ago, we’ve fixed most issues encountered, and added necessary documentations. Below are some of the important changes to bring to your attention:

    • We’ve rolled out the new website, with more stylish webpages, cart, forum, and support system. Over time OpenSprinkler related content will transition to the new site.
    • Four video tutorials are added to cover OpenSprinkler Installation, Firmware 2.1.0 Overview, WiFi connection, and Firmware Upgrade. These will hopefully help users to upgrade to the new firmware and take a quite tour of the highlights of firmware 2.1.0. Please visit to check them out.
    • A detailed, self-contained user manual is added, and detailed API documentation is added. Again, the documents are available at
    • It’s highly recommended that you upgrade to firmware 2.1.0 as soon as possible. Even if your controller is already running firmware 2.1.0 it’s recommended that you flash it again because it’s likely you are running the beta version (your programs and settings are preserved if you are uploading a firmware with the same version number as you already have).

    For detailed firmware changes, please refer to the forum post about the beta version.





    I’m trying to update my DIY v2.2 OpenSprinkler to firmware v 2.1.0 via a MacBook Pro running OSX 10.10.

    I’m trying to follow instructions via this video:

    And I’m using the links in the video for Updater 2.0, Mac Driver CH341SER, and the instructions there.  I have ensured that the Updater is not blocked by Mac system security.  I am able to download the latest Firmware using the Updater just fine, but if I click “Detect Hardware” it simply states it failed and selecting my hardware/firmware combination from the dropdown lists and choose “Upload Firmware” results in the following Error Log:

    ====== Sun Oct 26 14:18:40 2014 ======

    avrdude: ser_open(): can’t open device “unknown”: No such file or directory

    ioctl(“TIOCMGET”): Inappropriate ioctl for device

    avrdude done.  Thank you.


    ====== Sun Oct 26 14:18:40 2014 ======

    Error uploading firmware.

    I also use AVRDUDE when I’m programming with my Arduino and various Arduino compatible hardware.  Not sure if that is an issue.

    Just to clarify, since I’m on hardware 2.2, I do not need to enter Bootloader mode, correct?






    I was able to update the firmware easily via a Windows 7 machine I had in the house.  Not sure what the Mac problem was, but it wasn’t the Opensprinkler hardware.

    I then got everything cleaned up outside.

    All Set OS and Wi-Fi setup is complete.



    The firmware updater program is written in Qt. There is a known issue of current Qt’s SerialPort class crashing in MacOS 10.9.5 or 10.10 ( Fixing it requires re-compiling the SerialPort library, which I haven’t had time to do yet. Good to hear that you got it working on Win7, and thanks for posting the picture. Looks nice!




    I have 8 OpenSprinkler 2.1’s that I use to irrigate my home garden and Citrus properties. I went around today and upgraded them all to the new 2.1 firmware from 2.09.

    I think I have found a bug in that I have imported the old settings/programs and am then re-naming them, and change them to a fixed start time instead of repeating. When I “save changes ….” it makes a new program with the new name I chose and the old program 1 is still in the program line up. When I try to delete the “program 1” the prompt box says “are you sure you want to delete program 2?” instead of program 1 and if I click yes program 2 is deleted and not program 1. When I renamed program 2 the same thing happens with the original program 2 still being there and the new renamed program as well. And if I try to delete program 2 it says delete program 4.

    Also on renaming program 1 and program 2 an extra program 5 is in the list which I haven’t touched (see screen shot).

    In the preview programs, everything is as it should be with the renamed program 1 and 2 showing up as expected and no extra programs.

    I am using the web interface in Chrome on my PC to make these changes. I have attached the backup settings from 2.09 from the unit I am talking about.

    Overall I am very happy with the units and the new firmware will make programing the devices easier and less confusing (especially dealing with the multiples of units I am running).

    Thanks for your hard work.





    This is the first time I’ve updated my firmware.  I think I started with 2.05 or 2.06.  The issue I ran into was installing the driver as I’m running 2.1 hardware.  At first I attempted to install the driver (Windows 7 64-bit) with libusb_0.1.12.1 as indicated when you talked about Windows 8 installation.  This didn’t work so I thought I had to disable driver signature enforcement.  A quick google search and a reboot later and I tried to install the driver again.  Same result.  Then I uninstalled the driver and tried the other driver libusb_1.2.40 and it installed.  So I turned driver signature enforcement back on.

    The point in this exercise is I don’t think driver signature enforcement is required for Windows 7 64-bit and it was never mentioned which driver should be installed.  Considering Windows 7 still holds the majority of OS share, I think it’s important directions should also cover Windows 7.  Your instructions seem to indicate Windows 7 and 8.x 64-bit should be lumped together.  Even if this was the case, the video instructions would indicate to install the first driver which did not work in my case.

    A simple:  for Windows 7 users choose libusb_1.2.40 would have sufficed.  Even linking directly to the drivers from your webpage would be helpful rather than to the website where the drivers are located.  It doesn’t appear they update the drivers frequently as they are dated from 2011.

    This is the first time I also added the uSD card with this major firmware update.  I think I read somewhere where it was advised to remove the uSD card before updating the firmware.  Is this a requirement?  I don’t want to have to remove the 4 screws unless I have to for future updates.

    I also noticed that the static IP address didn’t keep when I restored my settings so I had to go in the advanced settings and turn off DHCP and manually set the IP and gateway again.  Has this been addressed in this firmware or is that by design?



    @CuriousG In regard to the SD card, I have been flashing very frequent (daily) while leaving the SD card in, without issues. I think it should be safe to leave the SD card in when upgrading.

    For the DHCP, prior apps didn’t backup the DHCP setting however moving forward with firmware 2.1 and the app versions supporting it, these settings should restore in the future.



    @philkr: thanks for supporting OpenSprinkler and for reporting the bug. I think I myself may have seen an instance of the issue you reported. One thing to note is that each program is given a default name: Program 1, Program 2 and so on. When a program name is left empty (i.e. not given), it will show the default name. However, since a program can also be assigned a custom name, Program 1 may have a name that’s called Program 2. So when programs have such names, it can become confusing especially after reordering them. We will see if we can reproduce the issue you reported.

    : I’ve always used the driver in the libusb_0.1.12.1 folder, including when I installed it on Windows 7 64-bit. The solution you described (using libusb_1.2.40) seems to work for Windows 7 64-bit, as that version is a partially signed driver (and Windows 7 seems to be ok with partially signed driver). But I don’t think it works for Windows 8. In any case, will check this again later. I only use Linux and Mac on a day to day basis, so I need to find a computer with Win 7 64-bit to test again.

    Regarding removing SD card: that’s only necessary for an early batch of OS 2.0, which did not have a pull up resistor on the SD card’s chip select pin (as a result, the SD card interferes with the firmware upgrade process). Unless if you have a very earlier version of OS 2.0, there is no need to remove SD card.




    I’m just reporting to you what worked for me.  The driver definitely didn’t work when I used the one in libusb_0.12.1 for Windows 7 64-bit.  It pretty much is a fresh install with only Microsoft Office 2010, Chrome and Adobe Acrobat Reader installed.  Maybe some other people can get into the driver issue discussion that has it installed on a Windows 7 system.

    Regarding the SD card issue, I’m happy to report I’m running v2.1 of the hardware so I won’t have to worry about removing the card for each firmware update.

    : thanks for the updated information regarding manual IP address setting.  No offense Ray but the UI looked liked ass prior to Samer unifying browser and the mobile app.  🙂

    Great job guys.



    Just to quickly point out that I’ve found a fully signed USBasp driver that works in all versions of Windows. So no more messing with driver signature enforcement any more.  Details are in this blog post:


    Phil Maron

    I have just received my new OpenSprinkler preloaded with Firmware 2.1 but I am having problems with the time sync capabilities. I have set my location correctly to Melbourne, Australia but the time displayed appears to be Australian Eastern Standard Time rather than Australian Eastern Daylight Savings Time. I have tried disabling the NTP option and manually setting the time and then setting it back to use NTP but it is always an hour out. I have also tried a number of different locations in the same time zone with similar results. At this stage I have set the time manually but I am wondering if this is a bug or is it simply ignoring DST. Any help would be appreciated.



    I just tried it on my testing OS, and I think it’s setting time correctly based on your location. To check:
    1) make sure Use NTP is flag on
    2) set location to Melbourne,Australia
    3) wait for the controller to update time
    4) if the time looks wrong, check http://x.x.x.x/jo?pw=your_password, where x.x.x.x is your OpenSprinkler’s IP address. Look for the ‘tz’ parameter, it should be 92 (according to your current time zone and DST).


    Phil Maron

    When I browse to that URL, all I get is a short string of text that reads :




    Phil Maron

    With a bit of playing around I’ve managed to get it sorted out. I have no idea what happened but I had to reset the device back to factory default and start from scratch. This time it seems to be working. Thanks for your help anyway Ray.



    OK. Thanks for the update.



    Exciting release! I’ll get updated eventually, but irrigation off here now, so no way to verify anything.

Viewing 16 posts - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware Announcing the official OpenSprinkler Firmware 2.1.0