OpenSprinkler Forums OpenSprinkler Mobile and Web App Bug in ‘Activate Master’ setting in ‘Edit Stations’

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #23052


    Hi Samer,

    I think I’ve stumbled on a small bug in the per-station setting of ‘Activate Master’ in the ‘Edit Stations’ area.

    My setup:
    Native App version 1.1.1 running on iOS7.1.2 (iPhone)
    OS 2.1 + Expansion Board (“Extension Boards” set to “1” in OS Settings)
    Station 1 is “Master Valve” (Master)
    Stations 2 through 10 are regular irrigation zones

    I want ‘Activate Master’ enabled for stations 2-10.
    I want it disabled for stations 11-16 which are unused (i.e. don’t want to pressurize the system if I accidentally activate one of these unused stations).

    Steps to reproduce:

    * Go into “Edit Stations”
    * Manually unselect (i.e. tap so that blue coloring goes away) the ‘Activate Master’ for one or more stations (in my case: unselect stations 11-16)
    * Submit
    * Go into “Edit Stations”
    * You will see one *fewer* stations have ‘Activate Master’ enabled than was previously set (i.e. for me station 10 has ‘Activate Master’ disabled, but it shouldn’t have been)

    Workaround for me is to enable ‘Activate Master’ for stations 2-11, submit, and when I come back to check it, it is set on stations 2-10 which is what I actually want. Or I can set this from the web interface.

    Let me know if you are unable to reproduce or if my description is unclear and I’ll post screenshots.



    Thank you for letting me know! I found the bugs causing this (yes, multiple mistakes) and have already fixed them. I will try to get an update pushed out soon to handle this but will probably wait a few days for possible language translations for other recent changes.

    Thanks again!



    I’ve discovered another issue with the “Activate Master?” option.

    My hardware configuration is as follows:
    o OpenSprinkler V2.0 hardware with a 2.0GB MicroSD card added.
    o Firmware/Software Version is 2.09.
    o There are three additional 8-channel zone expansion (clear case) connected to the OpenSprinkler V2.0 hardware.
    o Of the 32 Zones that can be controlled, 28 are in use.
    o Zone 1 is used to control a master valve.

    The problem I encounter is that after turning off the, “Activate Master?”, option for unused zones 30->32 and clicking Submit, zones 22->24 have their “Activate Master?” option turned off and zones 30->32 are still activated.

    This has obviously been detrimental to three areas of my yard. I should have tested before I let a week go by without watering…

    Just speculating, but since the zones being un-linked to the master zone are eight-off from the zones selected, there may be a small zone pointer or expansion module pointer calculation error?



    I am able to reproduce this and apologize for the bug!

    I have fixed it and it’ll make it’s way into the next version of the app.

    For the web interface (using http://os_ip), I have already pushed the fix so a refresh should resolve the issue.

    Thank you for the report!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Mobile and Web App Bug in ‘Activate Master’ setting in ‘Edit Stations’