OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Burned ospi and Raspberry Pi

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #37932


    Help needed!
    I just Got my ospi up and running yesterday, and this morning i Was ready to install it in my greenhouse.
    Its a + model with a b+ Raspberry pi to go with it.
    Well i plug in The power and The Green led lights up. Then i go to my car to Get a extension cord, wen i return it smells burned, i unplug The ospi an disconnects The Raspberry pi, i Can see that fuse 1 and fuse 2 are burned on The ospi!
    And worse still, so is The Raspberry pi, no visual damage but it is as dead as dead Can be.
    No change since yesterday besides The location!
    There is one solionoid connectet to The ospi, as it Was last Night, is should be turnes OFF in The ospi program, i since testet it directly to 24v ac, and it works fine! (There Was no core in The soleonoid)
    Also i Was never able to Get my Raspberry pi to boot on only The ospi power, i had to power it directly!
    Note that it Was only the 24v ac, that Was connectet at the time of the burnout!
    Could a power scurge, be The culpret here?
    If so How would you guard your ospi against it?

    ospi worked yesterday
    Ospi did not boot up Raspberry pi (only dim Green LED and a Quick red LED flash at first power)
    Only 24v ac on at The time.
    Fuse 1 and 2 burned (visualy inspected)
    1 soleonoid atached at The time, testet it works,should be OFF in The programme, had no core in at The time!
    Power scurge? Have a Big freezer on The same power group?
    Please help! Dont wanna do The same mistanke again!
    Se foto for burned fuses!
    With High hopes and eager to learn: The Danish Greenhouse gardener!



    Ok a bit of updates!
    The ospi gives 5v on VCC if fuse 1 is byepassed, so fuse 2 is proberly ok even though it looks toasted.
    Is The Green LED meant to be that bright, noticed The brightness earlier, but it gets so hot you Cant hold your finger on it, after a fem minuts?



    The green LED does look very bright. This is probably because the manufacturer used a green LED that’s different from our original spec. The current flowing through the LED is about (5-2)/1K = 3mA, which is pretty normal. But if the brightness bothers you, you can remove the green LED or the 1K resistor next to the LED.



    Ok Well it dont bother me but thought it might be an inticator of to much power exc.
    But good to get that ruled out!
    I still wery much hope that someone Can help me out!
    I have No idea what it Wrong and I dont have much more money to spend on burning pi’s!



    I thought you said OSPi gives 5V if fuse 1 is bypassed — that means it’s working. What other issues are there?



    We got it up and running again, yesterday. 🙂
    the issue was that it burned out the Raspberry!!
    still noreal idea why, but my teory is that it was due to the core of the soleonoid being out.
    my elektronics guru says that, the inductans on the soleonoids rise x3 wen the core is in (activated) thus it uses way more power without the coil in!
    dont know if that makes sence to you guys, it is beond my mere skills.
    but we cut the new pi´s power pins, and run seperate power to it now, just to be shure.



    Sure, what you described is the ‘inrush current’, which is typically 2-3 times the holding current. Still, that shouldn’t have burned out the RPi.



    I know!
    But it Burned out allright any ways??



    I need Help for my OsPI.
    today I grilled my OsPI. It seems like F2 and D3 are broken. When I plug the OsPI to the Power Supply, then it begins to spark and to smell. What can I do? Can I fix this on my own, or do I need a new OsPI ? :((

    Thanks fo Help




    I have the same problem. Yesterday my F2 burned.

    I got my ospi last August, but had no time to try. Yesterday I got my transformer. Firt I tried without the raspi, and the LED worked. Then I connect the raspi V2 and connect the 24V and the F2 start to smoke, so immediatly disconnect the power and remove the raspi. The raspi is not dead, but the F2 look like the picture from the post above.

    Then I tried again without the raspi, and the LED still work. I tried the 2nd pin (5V) and the 6th pin (ground) with a multimeter. There I get 36V. This is strange. I don´t like to try again with the raspi. I´m afraid to kill it.

    What can I do? 🙁



    Hi Pascal
    Had a look, seems to be bad soldering…. Looks like the F2 got HOT



    @scirocco3r, I see that you’ve submitted a support ticket and we will arrange to ship a replacement board to you right away.




    I bought my OSPi some time ago, I am guessing a couple years ago so my purchase may be close to the same time as the others in this thread. Finally getting around to changing over to this. When I powered up the board with 24VAC with the Pi installed there was a puff of smoke so I pulled the power immediately. There is a burn mark next to F2. The fuse tests ok when the meter probes are placed on the terminals on the fuse but when I put them on the pads on the board it shows open. The solder is minimal but looks connected. Obviously it isn’t. I am considering touching up the solder on this part since I work on this type of stuff regularly. Seems like this might have been a processing problem at the time since others had the same issue? Fortunately my Pi B+ still runs and appears to be ok. Please advise.




    Where is a parts list for the OSPi version 1.42+?

    Would also like to get a parts list for the zone expansion board.



    Doh… In looking over my wiring it looks like I misconnected output of OSPi to output of expansion zone shorting the power supply. The regulator is now shorted and outputs 37V instead of 5V. Not sure if I will try to repair this myself or send it in. Still would like to get a parts list. The only one I found on line (github) is way out of date and uses a different part number regulator.

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Burned ospi and Raspberry Pi