OpenSprinkler Forums OpenSprinkler Unified Firmware Difference between local weather service WL and Opensprinkler logged WL

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by  matthew garton 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #61675

    matthew garton
    Participant

    Like many I have been monitoring what has been happening with the changes since weather underground and I think the team is doing a great job. This is particular evident in this post;
    https://opensprinkler.com/forums/topic/current-state-of-the-weather-script/

    My own research is showing inconsistency in watering percentage logged by OpenSprinkler and retrieved through the API and the data returned by the weather service.

    The specifics are this – the opensprinkler log is showing the watering level at around 3% but the weather service is showing that it should be more like 87%. This discrepancy is not explainable by me after I have tried checking the obvious things like same location, temperature, humidity, and rainfal sensitivity setting in the Zimmerman method.

    Here is what I have done:
    I am using a RPI 3
    I have setup the local weather service using these instructions:

    I am able to get a result on my local system by calling this url through a browser: http://192.168.1.120:8081/weather1.py?loc=-33.76053,151.06980&wto=%22h%22:100,%22t%22:100,%22r%22:100,%22bh%22:70,%22bt%22:59,%22br%22:0
    The result looks like:
    &scale=87&rd=-1&tz=88&sunrise=419&sunset=1026&eip=3232235785&rawData={“h”:58.63,”p”:0,”t”:53,”raining”:0}

    The key being that the scale setting returned shows: 87%.

    In the opensprinkler UI I set it up to use the local weather service ( attachment 1). For any one readin who does not know this was done by going to : http://192.168.1.120:8080/su
    Perhaps the only odd thing about this setup is the use of localhost rather than IP but the UI is happy about and shows that weather service calls are successful.

    After a couple of days I started to compare the results. First I pulled the data out of opensrpinkler’s log:
    http://192.168.1.120:8080/jl?pw=…..&hist=0&type=wl
    This returns:
    [ [ 0, ‘wl’, 7, 1563235927 ],
    [ 0, ‘wl’, 6, 1563239529 ],
    [ 0, ‘wl’, 6, 1563243132 ],
    [ 0, ‘wl’, 6, 1563246734 ],
    [ 0, ‘wl’, 3, 1563250335 ],
    [ 0, ‘wl’, 3, 1563253937 ],
    [ 0, ‘wl’, 3, 1563257539 ] ]

    This shows a consistent WL of around 3% vastly different from the 87% the weather service is returning!

    I checked the data being supplied to the weather service call and the setting in Opensprinkler and they appear the same. Please see attachment 2

    I also calle the api to check the settings there: http://192.168.1.120:8080/jc?pw=
    This returned
    {“devt”:1563258291,”nbrd”:1,”en”:1,”rd”:0,”rs”:0,”rdst”:0,”loc”:”-33.76053,151.06980″,”wtkey”:””,”sunrise”:419,”sunset”:1026,”eip”:2130706433,”lwc”:1563257539,”lswc”:1563257539,”lupt”:0,”lrun”:[1,2,396,1563181597],”sbits”:[0,0],”ps”:[[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0]],”wto”:{“pws”:””},”ifkey”:””}

    Interestingly all the settings for WTo are not set. I assume that is due to the lack of uSD stated in the API doco but not sure how works.

    At this point I am unable to see what I have configured incorrectly between the local weather service data and what is being logged in opensprinkler. Any insight would be great.

    #61701

    Ray
    Keymaster

    Can you check the http://192.168.1.120:8080/jo?pw=.. result? Or you can simply do a http://192.168.1.120:8080/ja?pw… which prints out all settings. The fact that your wto is basically empty means your Weather Adjustment Method has not been set to Zimmerman (it might also be due to other reasons such as you were trying to use WU API key which is not supported any more). In any case, if you can print out the /ja page I can take a look at what settings may be wrong.

    I assume you are running firmware on OSPi or Linux-based system, because on the microcontroller-based OpenSprinkler (OS 2.x or 3.0), using your own weather service does not support custom port number (the :8081 is not supported on those systems).

    #61715

    matthew garton
    Participant

    Hi Ray,
    Thank you for your response. Yes I am running OSPI.

    When I read this I was worried that giving you /ja would not work because I had just run firmware upgrade in the hope that this would reset everything.

    For complete transparency that is I did:
    1. git pull
    2. sudo ./build.sh ospi
    3. sudo /etc/init.d/OpenSprinkler.sh restart

    After that I set the location and set the Zimmerman method (please note UI screenshot attached).

    I have run /ja but the settings for WTO appear the same
    http://192.168.1.120:8080/ja?pw=

    Result:
    {“settings”:{“devt”:1563424259,”nbrd”:1,”en”:1,”rd”:0,”rs”:0,”rdst”:0,”loc”:”-33.76055,151.06971″,”wtkey”:””,”sunrise”:418,”sunset”:1027,”eip”:1997669300,”lwc”:1563417948,”lswc”:1563417948,”lupt”:0,”lrun”:[0,0,0,0],”sbits”:[0,0],”ps”:[[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0]],”wto”:{“pws”:””},”ifkey”:””},”programs”:{“nprogs”:0,”nboards”:1,”mnp”:34,”mnst”:4,”pnsize”:20,”pd”:[]},”options”:{“fwv”:218,”tz”:88,”hp0″:144,”hp1″:31,”hwv”:64,”ext”:0,”sdt”:0,”mas”:0,”mton”:0,”mtof”:0,”urs”:0,”rso”:0,”wl”:5,”den”:1,”ipas”:0,”devid”:0,”con”:150,”lit”:100,”dim”:50,”uwt”:1,”ntp1″:50,”ntp2″:97,”ntp3″:210,”ntp4″:169,”lg”:1,”mas2″:0,”mton2″:0,”mtof2″:0,”fwm”:4,”fpr0″:100,”fpr1″:0,”re”:0,”dns1″:8,”dns2″:8,”dns3″:8,”dns4″:8,”sar”:0,”ife”:0,”sn2t”:0,”sn2o”:0,”reset”:0,”dexp”:-1,”mexp”:8,”hwt”:255},”status”:{“sn”:[0,0,0,0,0,0,0,0],”nstations”:8},”stations”:{“masop”:[255],”ignore_rain”:[0],”masop2″:[0],”stn_dis”:[0],”stn_seq”:[255],”stn_spe”:[0],”snames”:[“S01″,”S02″,”S03″,”S04″,”S05″,”S06″,”S07″,”S08″],”maxlen”:24}}

    I will attempt to fully purge opensprinkler from the device and install again.

    Thanks for any further insights.

    Attachments:
    #61717

    matthew garton
    Participant

    Update.

    I fully deleted the firmware and re-installed it.

    I updated a location setting and set to Zimmerman method and the /ja looks better now – ie it has relevant WTO settings

    They look like this now:
    {“settings”:{“devt”:1563426147,”nbrd”:1,”en”:1,”rd”:0,”rs”:0,”rdst”:0,”loc”:”-33.76047,151.06958″,”wtkey”:””,”sunrise”:418,”sunset”:1027,”eip”:1997669300,”lwc”:1563426128,”lswc”:1563426128,”lupt”:0,”lrun”:[0,0,0,0],”sbits”:[0,0],”ps”:[[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0]],”wto”:{“h”:100,”t”:100,”r”:100,”bh”:30,”bt”:69.98,”br”:0.394},”ifkey”:””},”programs”:{“nprogs”:0,”nboards”:1,”mnp”:34,”mnst”:4,”pnsize”:20,”pd”:[]},”options”:{“fwv”:218,”tz”:88,”hp0″:144,”hp1″:31,”hwv”:64,”ext”:0,”sdt”:0,”mas”:0,”mton”:0,”mtof”:0,”urs”:0,”rso”:0,”wl”:84,”den”:1,”ipas”:0,”devid”:0,”con”:150,”lit”:100,”dim”:50,”uwt”:1,”ntp1″:50,”ntp2″:97,”ntp3″:210,”ntp4″:169,”lg”:1,”mas2″:0,”mton2″:0,”mtof2″:0,”fwm”:4,”fpr0″:100,”fpr1″:0,”re”:0,”dns1″:8,”dns2″:8,”dns3″:8,”dns4″:8,”sar”:0,”ife”:0,”sn2t”:0,”sn2o”:0,”reset”:0,”dexp”:-1,”mexp”:8,”hwt”:255},”status”:{“sn”:[0,0,0,0,0,0,0,0],”nstations”:8},”stations”:{“masop”:[255],”ignore_rain”:[0],”masop2″:[0],”stn_dis”:[0],”stn_seq”:[255],”stn_spe”:[0],”snames”:[“S01″,”S02″,”S03″,”S04″,”S05″,”S06″,”S07″,”S08″],”maxlen”:24}}

    I will monitor this a for a few days and see if the weather service and open UI are now aligned. I will come back if they are not. Thanks for the consideration.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware Difference between local weather service WL and Opensprinkler logged WL