OpenSprinkler Forums OpenSprinkler Unified Firmware How to Debug Remote Station function

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #42038


    I have two Open sprinkler pis. They can ping each other on a 192.168.0.x network. Here are the pi hostnames and ip addrs: pond-sprinkler garage-sprinkler

    The pond-sprinkler controller controls a pump relay. That’s on station #1 on that controller. It works fine and turns on when any zone on the pond-sprinkler controller is on.

    I also want to turn the pump relay on whenever a valve controlled by the garage-sprinkler is on. So, I configured a “remote station” on the garage-sprinkler controller that points to, port 8080.

    But it doesn’t work. How to debug?

    The garage-sprinkler firmware apparently “sees” the pond-sprinkler, since it complained about it not being configured as an extender when I set up station #1 as a remote station. That really confuses me, but it doesn’t work whether I say yes or continue to a prompt asking if I want to configure pond-sprinkler as an extender. I have no clue what that means–pond-sprinkler is not an extender, it’s an OSPi.

    Maybe related–I have to access the firmware on garage-sprinkler on port 80, not 8080. Even though the opensprinkler gui says its on port 8080. When I try accessing //garage-sprinkler:8080, the browser looks like its trying to go to Even when I do

    This pi was configured for that ip address, but no longer. And I’ve checked that my windows hosts file doesn’t have a record for that. And, nothing outside of the browser trying to access garage-sprinkler. I.e, I can access that pi from other computers on the network either by name (garage-sprinkler) or

    I stumbled on to the fact it seems to work when I used port 80, instead of 8080. Maybe this wierdness is related to my problem with a remote station?

    On the pond-sprinkler, using // or //pond-sprinkler:8080 works.

    What’s the best way to debug this?




    Got it working!

    Turns out if I specify anything other than the master station on the remote controller (pond-sprinkler), it works.

    So, it looks like I just have to define a “dummy” station on the pond-sprinkler that controls no valve directly, but has the “Use Master” flag set.

    The remote station is a master on the garage-sprinkler controller, so it will active the remote, dummy station on pond-sprinkler when any station (using master) on garage-sprinkler is on.

    Still don’t understand the “configure as extender” thing, or why garage-sprinkler is on port 80 instead of 8080. But, I think I can get things working.



    ‘configure as extender’ is just a recommendation that you should set the remote controller in ‘extender mode’. In this mode, the controller does not run any program, and does not check weather data etc. It’s just to make sure that the remote controller will only listen to the master controller, and will not unexpectedly start a program on its own. You can ignore the message if you are sure you are doing the right thing.



    Thanks for the explanation, Ray.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware How to Debug Remote Station function