Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #46453


    Hoping someone can help me with a multitude of issues.

    On edit, short version here, long version below.

    Short Version

    1. A while ago one of the solenoids got stuck and burned out the fuse in my OSPi so I replaced it. Didn’t notice at the time I bought slow blow fuses instead of fast
    2. Had a major leak in one of the sprinkler boxes where two valves “live”, repaired the leak then noticed one of the valves when operated through OSPi would chatter and cause water to come out the back flow preventer by the main valve.
    3. Since the two valves were old anyway, went ahead and replaced all the pipe and values inside the box.
    4. Operated the value that was not chattering and all seemed good but when the chattering valve was operated smelled burned electrical coming from the OSPi. This is when I discovered my mistake with the slow blow fuse and replaced it with fast blow.
    5. OSPi seems to operate normally on all former zones except the one that was chattering, this zone shows ~7VAC all the time no matter the state of the zone
    6. I was going to switch the chattering zone’s wiring to another unused zone on the expansion board but now noticed that all of the formerly unused zones are also putting out ~7VAC no matter the state of the zone

    Is there something I can check and repair or did I screw up the OSPi and need to buy a new OSPi and expansion board?

    Long version

    Sorry for all the details but hopefully it explains the sequence.

    A while back on one of the zones’ solenoid got stuck and it burned out the OSPi fuse so I had installed a new one I also didn’t like that the Pi itself lost power when the fuse blew so I created a fuse block for each zone to have it’s own fuse. I didn’t realize it at the time but I installed slow acting fuses both internally to the OSPi and in my fuse blocks. Also inside I installed a 2A fuse and not the 1.5A like I did outside, I bought both 2A and 1.5A and intended to put a 1.5A inside.

    I have a sprinkler box with two valves in it with an additional nipple that was capped off. Came home to a massive leak at the nipple that had been going for an hour or more and flooded the back yard. Since the prior installer did not install a shut off valve in the box we spent two days without water to the property so that I could cut out the cracked pipe and install a shut off valve ahead of the manifold. Everything seemed fine for a day or so then when I went to turn the water back on for the two valves we noticed one of the valves kept chattering which was also causing our back flow to purge. The two valves were old anyway so I decided to replace both valves with a new ones. Since I had the new turn off installed I left the OSPi as normal and just disabled the two zones.

    In the mean time the transformer feeding the OSPi failed, the OSPi wouldn’t turn on and I checked the output of the transformer and got 3VAC and made sure it was getting 110+VAC on the input side which it was so I ordered a new one and replaced it. All seemed back to normal so figure it was just time for a new transformer, I pillaged it from the former sprinkler control box which was at least ten years old so figured it was just worn out from being in the 90+ degree garage all the time. In hind sight I don’t know but maybe the transformer was causing the chattering which ended up causing the pipe to crack.

    Once the new manifold and valves were cured and the new valves wired up I turned the water back on and thought my problems were behind me. I was standing in front of the OSPi, enabled the two zones and gave one a try. That zone worked great so I though all was fixed until I tried the other zone, the one that was chattering. Using the app I turned on the zone but didn’t hear running water so I checked the fuse and it looked good but then all of a sudden I smelled burning electrical so turned off the zone. I checked the fuse again and it was still good and the pi was still on so I knew something bad happened inside the OSPi. I grabbed a DVM and checked voltages. The transformer was good, OSPi was getting 26VAC, and the other zones all were getting 26VAC when I cycled them on through the app. At this point I turned everything off and pulled the OSPi apart and discovered the slow blow fuses and pretty sure I burned up the relay for that zone.

    I went and bought all new fast blow 1.5A fuses, took the one off of the OSPi and soldered a new one in it’s place, replaced all the ones in my external fuse block, and buttoned everything back up. All of the zones except the one that I was having trouble with worked fine, the bad one has about .7VAC on it no matter what state the zone is in (on or off in the app) which I figured means it is fried and maybe the switch is barely touch so it give a little voltage. I figured not a big deal although it is a bummer that zone is toast, maybe some point down the line I can replace the relay. Here is where it gets even more odd, I have a single expansion board and using three of the zones on it. They all work fine but all of the unused zones have 7VAC no matter if the zones are on or off. I have them disabled and they still have 7VAC so they are unusable.

    The question is, did I fry everything and need to order new OSPi and expansion board or just something in the OSPi is fried that needs to be fixed? If the latter any ideas on what and is there an easy was to diagnose? I have some soldering and electronics skills but not sure what to test at this point.



    Well, kind of solved my own issues.

    Apparently the zone that was “bad” actually had a bad solenoid in the new valve. I had another new valve so thought what the heck, I’ll try connecting just the solenoid to the zone and give it a go. Solenoid buzzed right away when activating the zone from OSPi so I screwed the new new solenoid into the valve and before firing it up went to check the voltage on the zone. Zero volts AC in that zone now! Just for fun I checked the other unused zones and they still show ~7VAC but the one I care about seems to be back in order so I used the app to turn on the bad zone and all is happy again. I tried the zone four or five times then let the normal program run yesterday and all seems well.

    Not sure why the unused zones are showing ~7VAC but I don’t have anything hooked up to them so not going to worry about it for now.



    The 7VAC is normal because it’s just stray voltage. If you have an actual solenoid (i.e., a load) connected to the zone the stray voltage should go away.

    Sorry that I didn’t read through your original post ’cause it’s quite long. But if there is any remaining issue, you can post it here again.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.