OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Network stops responding

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #22846

    galrot
    Participant

    Hello!
    I have bought and installed OSPi 1.3 with the preloaded SD card.
    I am using RPi B with the popular Edimax wifi adapter.
    There are 6 zones connected to the ospi, and everything works just great.

    But –
    Once in a while the wifi stops responding and I cannot connect to the sprinklers program. Once that happens, the programs continue to work as planned, I just cannot connect to the system to check logs and make adjustments. A forced reboot (pulling the plug 🙂 solves that problem for several hours, maybe days, but then it comes back.

    Did you meet this issue before? Is there a logging system on the preloaded card that I can check first?

    Thanks,
    Gal

    #26548

    Dan in CA
    Participant

    Gal,

    I was having the same problem you describe with a newly configured OSPi. Then I remembered that an older setup that was more reliable was set to a static IP address.

    I set a static IP address on the Raspi itself as well as on the router and it has not dropped the connection since.

    You can set a static address on the Pi by editing the file /etc/network/interfaces to look like:


    #iface eth0 inet dhcp #this line commented out
    iface eth0 inet static
    address 192.168.x.x #where x = your chosen IP address
    netmask 255.255.255.0

    Hope this helps.

    Edit:
    Nope. That didn’t fix the problem. I did discover that the image on the SD card was damaged. I re-formatted and re-imaged the SD card. So far it seems to be OK. Time will tell if this actually fixed the problem.

    Dan

    #26549

    QMan
    Blocked

    I had issues with my network too, but decided it was the power management setting on the Edimax wifi dongle as mentioned in this thread:
    viewtopic.php?f=34&t=423&p=2760&hilit=8192cu#p2760
    Step #6 shows adding a configuration file and it seems to be helping. That file would be located here: /etc/modprobe.d/8192cu.conf

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Network stops responding