OpenSprinkler Forums OpenSprinkler Mobile and Web App OS IP address changing


Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #48046

    Gregory Lemieux

    I have a noobie question:

    I successfully setup my wireless TP Link router in client mode to my OpenSprinkler 2.3 (with 2.1.6 Firmware) following the video instructions. I was able to log into the web app successfully using the osip shown on the OpenSprinkler screen. My problem is when I went back to log in a few days later, I wasn’t able to connect. I went out and checked the OpenSprinkler and found that the osip had changed. Why is it changing?

    For reference I’ve linked the TPlink to another range extending wireless router. Should I be connecting it directly (wirelessly) to main main router?




    Hi Gregory,

    how do You have configure the Wireless-Router? You must disable its DHCP-Server, if You have another Router (Your main Router) with DHCP active.
    The best and easyist way is disable DHCP on Your OS an give him a static IP adress:

    e.g. main router is an OS should be and HTTP-Port 80:

    OS settings
    Enable DHCP: No
    Static.ip1: 192
    Static.ip2: 168
    Static.ip3: 0
    Static.ip4: 100
    Gateway.ip1: 192
    Gateway.ip2: 168
    Gateway.ip3: 0
    Gateway.ip4: 1
    Http-port: 80

    DNS server.ip1: 192
    DNS server.ip2: 168
    DNS server.ip3: 0
    DNS server.ip4: 1



    We generally recommend setting fixed IP using the router’s DHCP reservation feature. You can bind a fixed IP to OpenSprinkler’s MAC address. If your router doesn’t support this feature (which would be quite rare as most modern routers support this feature), you can set a static IP on OpenSprinkler itself.



    I have a related issue where I have tried to use the routers DHCP reservation feature but it gives an error that says the MAC address displayed on my OpenSprinkler 3.0 is an invalid MAC address (2C-3A-E8-08-11-4A). Looks ok to me so not sure why it doesn’t work but a real pain trying to find the correct IP address each time I need to access the Android app.

    Also I have an OpenSprinkler Bee (I’m an OS fan boy!) and I cannot find the MAC address on this device and my router doesn’t report it but I would like to also fix the IP for this one as well.

    Any Help much appreciated.



    It sounds like the formatting isn’t quite right. You may want to try replacing the dashes with colons when entering the MAC address in your router. So put 2C:3A:E8:08:11:4A in there.



    Many Thanks BJ, that has fixed the newbie error 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Mobile and Web App OS IP address changing