OpenSprinkler Forums Hardware Questions OpenSprinkler OS3.0 with LAN Adapter – How to Disable Wifi

This topic contains 7 replies, has 4 voices, and was last updated by  bryant 1 month, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #61456

    Tim
    Participant

    Hi, I have a OS3.0 with the LAN adapter, but have found that on a reboot the OS will sometimes ignore the LAN adapter and wait for a WiFi Connection. If I power cycle the OS3.0 it will usually return back to using the LAN adapter, but sometimes I need to restart it multiple times.

    Is there someway for to permanently disable the WiFi side? Or force the ethernet adapter to be the primary connection method? Also I’m running a static IP, and there doesn’t seem to be an option to enter in a Subnet Mask? am I’m missing something with the setup?

    Thank you.

    #61548

    Tim
    Participant

    Any chance this could be looked at? Its sort of a big problem for us. From my testing this only seems to be a problem when setting a static IP. If I change back to DHCP the ethernet adapter stays connected all the time. Switching to a static address and about 1 in 3 reboots the wifi will take precedent and I get no connectivity via the ethernet.

    Thanks

    #61556

    asalassd
    Participant

    I haven’t had this problem with the OS3.0 + LAN adapter, but I assign the OpenSprinler’s IP address within my router config based on the MAC address of the OpenSprinkler. The OpenSprinkler continues to use DHCP, but it will always be assigned the correct IP address even after a full factory reset of the OpenSprinkler.

    #61592

    Ray
    Keymaster

    On OS 3.2, the Ethernet adapter works as follows: if it detects the adapter, and it can successfully obtain an IP address with the adapter, it starts in Ethernet mode; otherwise it boots into WiFi mode.

    To find out why it doesn’t go into Ethernet mode, first check if (upon power on) does it show a ‘Start wired link’ message? If so, that means it has detected the Ethernet adapter, and if consequently it quits Ethernet and boots into WiFi, then it must be because it can’t obtain an IP address. I don’t know the specific reason, but it could be because there is something wrong with the static IP settings (for example, IP conflict, incorrect gateway IP setting etc). Generally I recommend users to stay away from setting static IP, and instead use their router’s DHCP reservation to reserve a fixed IP. This way, the controller still gets a fixed IP but everything is managed through DHCP.

    Finally, if you purchased the controller from our German distributor, they had a first batch of OS 3.2 with a slightly outdated firmware, which may have affected static IP. The most recent firmware is 2.1.8(4) (i.e. minor revision 4), and is available here:
    https://github.com/OpenSprinkler/OpenSprinkler-Compiled-Firmware/tree/master/v3.0
    you can perform a OTA update (note that OTA update only works in WiFi mode, either AP or station mode is fine) to update your firmware to the latest. But I would say first try to set the controller back to DHCP, and use your router’s DHCP reservation to bind a fixed IP to the controller’s MAC address. If that resolves your issue, there is no need to update firmware.

    #61910

    Tim
    Participant

    Thanks Ray, No didn’t buy via the German distributor, purchased directly from your website.
    Typically we would use DHCP, however in this instance we are unable too (All of our other 10+ OpenSpinklers are DHCP assigned). There isn’t a IP conflict so that isn’t causing the issue, it just seems to be hit and miss between which adapter it selects on startup (Wifi or ethernet). Given you have a Static IP as an option, I thought the problem should be something that you would want to be aware of. Unless there is a fault with our unit, it should be fairly easy to replicate.

    On a side note, I don’t believe there is an option to specify a Subnet Mask when assigning a static IP address, seems an odd thing to not be able to specify.

    #61911

    Tim
    Participant

    We are already running firmware 2.18(4), App Version 2.0.2

    #61924

    Ray
    Keymaster

    So make sure we are on the same page, here is what I gathered so far: you said sometimes upon reboot the controller bypasses wired Ethernet and goes into WiFi mode, correct? I recommended you to NOT use static IP, but instead, leave the controller in DHCP and use your router’s DHCP reservation to reserve a fixed IP. Is that the case with your controller at the moment? Also, I am curious: if the wired connection succeeds at some point, why do you need to reboot the controller? It sounds like you need to reboot the controller several times but I don’t know why.

    There is no point forcing the controller in wired Ethernet mode: if the auto-detection fails, that means something is wrong with the wired connection (either there is a physical connection problem, or the controller failed to obtain a valid IP address from your router). So if we force the controller to be in wired Ethernet mode, it just won’t be accessible. For that reason, the firmware always goes into WiFi mode if the Ethernet initialization fails.

    It’s possible that the Ethernet module may have a problem and should be replaced. You can either send a support ticket to arrange for a replacement, or just search for ‘ENC28J60 module’ on amazon or aliexpress.com. Look for the ones with 2×5 pins. It’s a very common module that’s widely available.

    • This reply was modified 1 month, 3 weeks ago by  Ray.
    #62048

    bryant
    Participant

    i have had similar issues i have an os 3.0 with a lan adapter and i had i set up to my wired network it would occasionally drop the connection to my network
    and if the power went out i would have to cycle the controller to get it back on the network
    i changed it to the wireless setup it works just fine power goes out it always reconnects

    i have a reserved ip address by the mac address of the controller in a pf sense firewall
    which is the same setup that i used with a 2.3 the slighty older version of your controller for a long time it works flawlessly
    i can try an recreate the situation again when i have more time

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler OS3.0 with LAN Adapter – How to Disable Wifi