OpenSprinkler Forums OpenSprinkler Unified Firmware OSPi Not Functioning After Software Update

  • This topic has 7 replies, 4 voices, and was last updated 7 years ago by Ray.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #46063

    gadgetboy
    Participant

    Greetings, folks.

    I have an OSPi that I built last year using a Pi 3 and an expansion board. I run each zone sequentially so as not to tax the power supply and have had no issues.

    I booted it up and tested it earlier today, then I decided to install the latest update.

    Stupid me: I forgot to backup my configuration, so I had to set it up from scratch. (I only have 11 zones at the moment, so it was easy enough.)

    After reconfiguration, I cannot produce a positive result from any zone.

    I’m using zones 1-8 on the Pi and zones 9-11 on the expansion board. The Master is Zone 16.

    I rebooted the OSPi, recycled the power on the irrigation system without success.

    I’ve troubleshooted everything based on the manual, forums and other docs.

    Any suggestions on what I could be missing? Is anyone else have an issue after the update?

    Thanks in advance.

    #46126

    Ray
    Keymaster

    Which version of OSPi do you have?

    #46196

    gadgetboy
    Participant

    App Version: 1.6.0
    Firmware: 2.1.7
    Hardware: OSPi – AC

    #46330

    Ray
    Keymaster

    Has the issue been resolved? I really don’t know what could have caused this. If you want to give it a try you can always downgrade to firmware 2.1.6, but I doubt if this has to do with firmware 2.1.7 itself — the firmware has been out for quite a while and I am not aware of this being an issue for OSPi.

    #46418

    gadgetboy
    Participant

    Not yet resolved.

    I agree – it shouldn’t be an issue with the firmware itself but that’s the only change that occurred in the configuration.

    Looks like I’ll have to wipe it and start fresh in order to pinpoint the issue.

    I have to do it soon since it’s going to start to get really hot here in Austin.

    Any tips are appreciated.

    #46494

    herb
    Participant

    I’m having the same problem. Same software and hardware version as gadgetboy. The OSPi ran fine from 2013 through last season with the original (2013) firmware. I upgraded to the latest (2.1.7) and none of the stations run. The Raspberry Pi is a Model B Rev 2 (000d). Are there any known issues with older hardware and newer firmware?

    The power supply is putting out 26 volts AC. I checked the voltage across the terminals when a station was set to run manually – nothing. I checked /etc/modules, w1-gpio is not listed (only snd-bcmXX).

    Are there any other troubleshooting steps I can take, hardware or software? How can I get older firmware versions to try downgrading?

    #46690

    douglas_rick
    Participant

    Hi,
    I don’t know if this helps but I also have an older Raspberry Pi Model B. I successfully installed the 2.1.7 firmware without any problems. I previously had the 2.1.6 firmware installed and was able to do the update from within the 2.1.6 app. In the past I always did a git pull to get the latest update. Have you tried deleting the current firmware you have installed and updating from the repository instead of overwriting the old firmware?

    -Doug

    #46751

    Ray
    Keymaster

    One thing you can try is to run the firmware in command line and see if there is any error message printed out. To do so, first follow instructions here:
    https://openthings.freshdesk.com/solution/articles/5000631599-installing-and-updating-the-unified-firmware#stopall
    to stop the firmware from running automatically. Then go to the folder where the firmware is installed (e.g. /home/pi/OpenSprinkler-Firmware), and run
    sudo ./OpenSprinkler-Firmware
    This will launch the firmware in command line, where you can see debugging messages. When you start a program or manually start a zone, see if there is any error message that could be related.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware OSPi Not Functioning After Software Update