Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #34453


    I have the 1.4 version of the OSPi board and a model B Pi.   I have edmax Wifi dongle that is plugged into a powered USB hub.   the Pi is configured for wifi with wpa_supplicant and it works.    for about an hour then disconnects and i have to reboot it to get access to the web interface again.

    The OSpi keeps running and watering but no internet access.

    I have googled a bit and have tried

    turn of power savings

    ping default gateway to keep it alive.

    moving from the PI usb to the powered hub.

    OS and PI updates to the latest

    any ideas how to get a stable USB Wifi connection?


    Dave P



    I assume you are using the pre-configued SD card image linked from the OSPi 1.4 user manual:

    If not, please try the pre-configured image first. Also. have you tried plugging the dongle directly to RPi’s USB port?



    Thats where i started.   should I not update that image?   should it work out of the box?   I did try the wifi pluged direct into the PI but read that it may take too much power and brown out the Pi




    The pre-configured image has built-in driver for several common WiFi dongles, including the Edimax one. I suggest using the unmodified image first, if everything works fine, then try updating. That way you know which step is likely to have caused the issue. Also, I would leave the dongle in RPi’s USB port directly, unless if this leads to brown-out issue.



    I had the same issue, I installed the wicd-curses as the network manager. It solved all my issues.

    Follow this

    Or google “raspberry pi wicd”

    Hope this helps..

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.