OpenSprinkler Forums Hardware Questions OpenSprinkler Beagle (OSBo) Sprinkler valves do not open Reply To: Sprinkler valves do not open



Ray, I have got good news.  Your previous post did point me in the right direction.

The gpio module Adafruit_BBIO.GPIO was not installed. Once I installed that, I was able to run the self test programs and all the pins show output of 29.7 V A/C when each station is triggered. The “run once” feature in web application is also triggering the right voltage on the right stations.  I am yet to connect the unit to the valves. Waiting for daylight.

What went wrong? I think I got hung up in getting the wifi dongle to work. So in trying to configure the TP-Link TL-WN725N, I ran out of room on the 2Gb SD card (actually it is an 8GB micro SD card but when using dd to copy the osbo2.img file it only recognizes 2Gb). So I could not follow instructions to compile a driver for the wifi dongle. But then I ditched the micro SD card because the BBB comes with 4Gb eMMC flash storage built in. So booted with that version of OS. Built the driver. The wifi dongle was up but intermittent. Googling, I found 2 suggestions one which said to connect the wifi dongle using a USB cable or to disable the HDMI port (for whatever reason). Since I had no need for the HDMI port, I disabled it – but then I could not boot up the BBB using the OS on the eMMC built-in storage. I now had to find the OS on the internet and then flash that to the eMMC to bring it up. But I noticed that my version now was different and more recent than the one I had initially. But I went ahead and started using that, again downloaded all the required packages / source code to compile to make my wifi dongle work. That was successful and this time no intermittent signal, the wifi stood up always and was accessible reliably. Next I did a git clone to get Dan’s program and installed in /home/ubuntu. I decided to use the eMMC and installed the program. Did not want to use the micro SD card. Program installs fine and configured the init.d so that the program is executed at boot up time. However it was missing the Adafruit GPIO module. There was no errors in syslog. One thing I noticed that when I did the git clone to install Dan’s program, the demos folder never came through.  Your last post pointed me to the selftest program. So I went to the osbo2.img and then extracted the demos folder and put that in /home/ubuntu. And the problem was quite evident when I ran the program.

Long story – but I am a happy camper now. Can’t wait to plug this unit and get a better control of my irrigation of my landscape and conserve water.

Thank you for your support Ray. Really appreciate it. Though it was a bit of a struggle, overall, this was a nice learning experience for me. I learned quite a bit.