OpenSprinkler Forums OpenSprinkler Unified Firmware Linux (Ubuntu 14.04) won't recognize OS Reply To: Linux (Ubuntu 14.04) won't recognize OS



Okay, I now have the device recognized in Linux — if I hold down B2 for just the right length of time, I get:

[152334.596046] usb 2-5: new low-speed USB device number 16 using ohci_hcd
in dmesg.  But when I run osFWUpdater_x64 (after installing some half-gig of Qt and putting all the correct links to libraries in /usr/lib…), it just comes up with a blank window, no controls.  I’ve run it both as regular user and as root, no difference.

Moving back to my Win7 laptop and holding the button for just the right length of time, I was able to use the Zadig driver installer to install the libusb driver.  But when I run osFWUpdater.exe, I get an “osFWUpdater.exe has stopped working” message, with the following Problem Signature:

Problem signature:
Problem Event Name:    APPCRASH
Application Name:    osFWUpdater.exe
Application Version:
Application Timestamp:    00020020
Fault Module Name:    osFWUpdater.exe
Fault Module Version:
Fault Module Timestamp:    00020020
Exception Code:    c0000005
Exception Offset:    00002254
OS Version:    6.1.7601.
Locale ID:    1033
Additional Information 1:    0a9e
Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
Additional Information 3:    0a9e
Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

I distinctly remember seeing the Windows version of this program running sometime before installing the libusb driver (but of course it wouldn’t find the OS), so I have no idea why it’s failing to run now.