OpenSprinkler Forums Hardware Questions OpenSprinkler Instructions for testing OS 3.2 with W5500 Ethernet module Reply To: Instructions for testing OS 3.2 with W5500 Ethernet module


John K

Hi Ray,

Okay just spent some time trying to work through this. Here is what I found.

I reset the controller to factory default. From this point I can get into the controller App on PC/iphone just fine with Ethernet module plugged in. I uploaded my configuration file on to the controller and from then on I can only access the controller while in WiFi mode. In Ethernet mode, I can not get in, same issue as I stated above.

So I went back to factory default and decided to rebuild my configuration manually instead of uploading it. I did this while using the Ethernet mode. Got all my stations named (56 of them) and about 12 programs re entered when the controller locked me out again. At this point on I could not get into the App any more from PC/iphone while using Ethernet Module. I went back into WiFi mode and I was able to get into the App as I should be. Tried going into Ethernet mode a few times, no luck.

TO SOLVE: While in WiFi mode, I deleted about 4 programs that I had just entered, to shrink my configuration file size down. This worked. Went back into Ethernet mode and it lets me log in fine again. This reminds me of the buffer overflow issue you addressed with me a few months back, where you had to increase the buffer size to correct. So while in Ethernet mode, the configuration file is too large???? Hopefully this is enough info for you to find a the solution to this as I believe I am stuck now…