OpenSprinkler Forums Hardware Questions DIY Kit Assembly Questions 1.42u Setting up Ethernet Bridge – Network Connection

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #22495


    I have assembled a 1.42u kit and everything seems to be working well with the controller. I’m struggling a bit with the wireless to RJ45 bridge set up and was thinking someone here might know what to do.

    I’m using a BL-MP01 ‘mini router’ which is supposed to have a ‘client’ mode which allows it to act as a wireless to ethernet bridge.

    When I select client mode (also referred to as repeater mode in some documents for this device), I enter the Wireless network security settings and it connects to my network. The problem comes with the ip settings. At first I left the DHCP server in the mini-router on which was the default setting. My opensprinkler received an ip from it successfully but it was 192.168.16.nnn – the rest of my network is 192.168.15.nnn, subnet mask I don’t think I will be able to connect to opensprinkler if I leave it like this due to the subnet mask.

    So next I tried to disable the DHCP server on the mini-router with the hope that my main router’s DHCP server would assign a 192.168.15.nnn address to the opensprinkler device. It doesn’t seem to work. The opensprinkler just boots up “connecting to network…” then goes to the normal time screen. When I check the ip, it has as the ip, and I can not connect.

    This mini-router device has settings for WAN and LAN. In Client/Repeater mode the wireless network is the WAN side and the RJ45 jack is the LAN side. It seems to be acting as a router still, separating the two networks by the different address in the 3rd octet. I want it all to be on the LAN only. I’ve sent some questions to the manufacturer but the suggestions I got back are exactly what I’ve already done. Reboot. Redo the Wireless Security settings. Disable DHCP.

    Just wondering if anyone else has encountered this problem. When I get a few moments tonight, I will try setting a static IP of 192.168.15.nnn and see what happens.




    Not an ideal solution but if it won’t go into a true bridge mode, you could just DMZ the OpenSprinkler’s IP and set a static IP on the WAN interface (the wireless side).

    Of course, it would be better to find an option to truly disable routing but hopefully that at least gets some networking up for you.

    Edit: This guy seems to have it working in bridge mode: Might help.



    Thanks for your comments.

    I found a solution. It was not obvious, and somewhat contradicted any instructions that came with the device.

    For the BL-MP01, you need to put the selector switch to “AP Mode”. Once you do this, then different setup screens become available in the web configuration screens. There is a new screen called WDS (Wireless Distribution System) which allows you to select “Bridge Mode”. I think this WDS is intended mainly for setting up multiple APs to act as a single wireless network with one SSID – so in my mind bridge mode doesn’t really fit on this screen, but maybe something was lost in translation or I’m missing something. Anyway, once Bridge mode is selected, enter in the MAC ID of your main wireless AP, the WPA2 key, set up the BL-MP01 to use the same channel as the main AP. Reboot, connect the mini-router to the opensprinkler, leaving it set to ‘AP mode’ on the selector switch.

    Once I did this, then DHCP worked and the opensprinkler received a 192.168.15.nnn ip from my main router DHCP server. The ‘routing’ function seemed to be disabled, and I can connect through my normal PCs now without issues caused by multiple networks.

    Thanks again for the help.





    I have read your solution for converting client wifi BL-MP01, but it doesn’t work me.

    I followed your steps but I can not connect the computer on the same network.
    If I set it up the product manual (switch in Client Mode), the computer surfing the internet but not browse the local network.

    Could you export your settings and I try to make it?

    Or if you prefer, I export my settings and you correct the wrong parameters?

    Mi email is: [email protected]

    Thank you.



    I Can to connect it!! Thanks!!
    Only add:
    In AP CLIENT menu select Enabled. After appears SITE SURVEY in left tree menu. In Site Survey Connects to Router.



    I solved this issue. Set BL-MP01 Switch in AP-MODE.

    When you load this configuration, the minirouter make a transparent brigde (WDS). The device connected to RJ45 receive the IP from the Wifi Router.
    Important: In SITE SURVEY connects minirouter to desired Wifi.

    If you want connect to Minirouter:
    This configuration only permit you access to router by RJ45 with IP Set in computer same Network (p.e.



    Cool. Thanks for the update.



    Hello all
    I spent a lot of time with LB link BL-MP01 to put it it into client mode.
    You save my day…Now it works!!!
    But only if I set on my router fixed wifi chanal. If chanal is changed after time, the module is not conect to wifi.
    (The you make site survey the actual channal is set to MP01. If the wifi chanal is change to other the mp01 will not connect to wifi until you change chanal to first one).

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions DIY Kit Assembly Questions 1.42u Setting up Ethernet Bridge – Network Connection