OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) attached valve opens on power on

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #22804


    I am seeing some interesting behavior with the OpenSprinklerPi that has be a bit puzzled. I have a open sprinkler with a zone expansion board. When I power it on any valves attached to it open. The unit then does not respond to any commands sent to the web interface, through either the default program or the mobile program. I have detached the unit and am bench testing this with a valve right next to me

    Here is where it gets really interesting. The same behavior is not seen on the zone expansion board. On plugging the wire into the zone expansion board the valve stays closed.

    I did not experience this same behavior when setting up my Arduino based open sprinkler so it has me a bit puzzled

    Any and all help would be appreciated

    Thank you



    The expansion board uses a cable that requires a specific orientation. I can’t help but wonder if that might be the problem.



    I shall run the experiment. Let me completely disconnect the expansion board.
    interesting note. With it disconnected completely I am not having the valves open on boot.

    Unfortunately the valves themselves are still not responding to input.


    and thank you for the help



    Can you check if you are running the sprinklers_pi program or the interval_program (firmware 1.8.3)? Basically open a browser and type in
    where x.x.x.x is your OSPi’s IP address. From the webpage you can tell which program you are running.



    Thank you Ray.

    This is the site (http://x.x.x.x:8080) I am using for bench testing. To confirm I am using 1.8.3 firmware downloaded.
    I set it to manual mode. I have the valve controller set to station 1 with the common wire wired into the appropriate posion
    I turn on station 1 and nothing. The page refreshes correctly to what I saw in the arduino based system I have. I turn it off and nothing.

    I have tried stations 1-4 so far with similiar results. I have logging turned on so I see that it is correctly identifying which stations during testing are cycled through manual mode.

    I have also tried using multiple valves prior to bench testing.

    My wager is I am missing something very minor but very important, right now I cannot see that particular tree in this forest

    Thank you again



    Sorry that I lost track on this thread. Has the issue been solved? The other possibility I can think of would be the 8-pin ribbon cable — use a multimeter to check the connectivity on each line of the cable (the cable connectors have small openings that expose the metal pieces, you can use a multimeter probe to touch these and measure connectivity). Cable issues have happened in the past, so I won’t be surprised if one or two lines on the cable are disconnected. Also double check if you’ve plugged in the cable in the correct orientation.



    Thank you Ray. I have not solved this yet. I also am thinking it has to be the ribbon as it powers on just fine so the other point of configuration or user error would be the ribbon. I will check the ribbon orientation and placement now.

    I will let you know ASAP



    this is similar to what I was seeing when I setup my own image from scratch and did not have the Python GPIO Libraries installed.. you might check that you have them installed and there permissions are ok.

    but just today someone resolved a problem like this that turned out to be the ribbon cable for Pi; so that is the most likely culprit.



    Yep. that was the culprit. Misaligned a pin on the raspberry pi

    thank you

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) attached valve opens on power on