OpenSprinkler Forums Hardware Questions OpenSprinkler Cannot configure

  • This topic has 6 replies, 2 voices, and was last updated 1 month ago by Ray.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #67995

    AlanC
    Spectator

    Hi.
    I have an OpenSprinkler DC unit that I cannot configure.
    When I power it up the screen shows the IP address of 192.168.4.1
    I can put this address into my browser and it brings up a configuration webpage that says it is scanning for an SSID.
    It never finds the OS_****** id but can find other WiFi IDs on the network (my router)
    Manually typing in the SSID and pressing the submit button just sits there saying connecting at the browser and the module.
    I have updated the firmware to the latest version from your website via WiFi so that worked.
    I have tried different computers, tried with a wired connection etc for the last 3 days and nothing.
    What am I doing wrong.

    #67996

    AlanC
    Spectator

    Ok, progressed a little bit.
    Connected the notebook to the router (and internet) by a cable.
    Used wifi to access the controller.
    Set the IP to 192.168.210.100 (DHCP disabled as the site will not always have internet access)
    B1 button agrees that the IP is 192.168.210.100
    I can access the controller now by wifi but when I plug in the ethernet module (and restart the controller) there is no connection, not even ping works.
    I had to trawl through all the forum posts to discover that internet connection is required to access the controller because of Java.
    This detail (major detail) should be highlighted in the manual.
    Also in the app, what does opensprinkler name mean? there is no explanation, name is not mentioned in the program, or is it meant to be the name of the router/modem.

    #68002

    Ray
    Keymaster

    The IP address is NOT the same with WiFi vs. with wired Ethernet module. Please, always press button B1 to check the IP address assigned to it.

    “DHCP disabled as the site will not always have internet access” — I do not understand this — your router’s DHCP feature has nothing to do with Internet access.

    “internet connection is required to access the controller because of Java” — no, this is NOT true. You can use the OpenSprinkler mobile app which does not require Internet. It only requires Internet if you use a web browser to directly access the controller. Also, it does not use Java, it uses Javascript.

    #68010

    AlanC
    Spectator

    Hi.
    Thanks for the reply.
    Internet access was the wrong thing to say. A DHCP server may not always be available as the controller will be in a paddock remote from the router.
    I am not sure if the program will still run if there is a power cycle and it cannot find the DHCP server.
    I can now ping the controller over the wired connection on 192.168.210.100.

    When I reboot into wifi mode and press B1 the screen says
    Connecting to…
    192.168.210.100
    :80 (IP:port)
    Telstra7F2A5F2 “flashing diamond”

    Telstra7F2A5F2 was the modem I was connected to last night at home while testing the unit.
    Does it remember the last modem therefore I need to reset the controller?

    Also for the app what is meant by opensprinkler name? There is no name assigned to the controller that I can see in the configuration.
    Regards Alan

    #68027

    AlanC
    Spectator

    I reset the unit back to factory default.
    Powered it up and then entered 192.168.4.1 into a browser.
    Selected my router id and entered the router password.
    It sits there saying connecting forever. I can go to the unit and press the B1 button and it says the IP is set to 192.168.210.214 however the webpage still says connecting.
    Now I assume that the change of IP has caused the page to hang at “connecting” so I start a browser at 192.168.210.214.
    Password page pops up. enter password of opendoor and press submit. Nothing happens.
    Have also tried setting it to ignore password. Same result, the password page just sits there.
    Fastly losing confidence in the system.

    #68028

    AlanC
    Spectator

    Decided to try it with the wired connection. Re powered with the ethernet module connected, got the ip address and entered it into a browser.
    Entered the password, click submit and I get a popup asking if I want to save a .json file. Click save and then the submit and I get another popup asking about a different .json file.
    This keeps on until I get RSI and give up. The only way to remove the popup is to reboot the computer.
    What is happening???

    #68036

    Ray
    Keymaster

    I have never seen this issue. I suggest you use the Test OS API script:
    http://raysfiles.com/os/TestOSAPI.html
    and check the Json all /ja output and see if it’s valid.

    Also, you can always submit a support ticket:
    https://opensprinkler.com/forums/topic/forum-vs-support-tickets/

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Cannot configure