OpenSprinkler Forums Hardware Questions Locks up when changing stations

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #22503


    I am having a problem with the controller. It has been working fine for quite some time until the heat hit us in Las Vegas…at least that is when I noticed the problem – last night. Up until this morning, I thought there could be an overheating issue since the controller was installed in the garage and just so happened to be on the same wall that the afternoon sun beats on. The problem at hand seems to be when a program is running, the screen goes blank (still on – no text), when it switches to the next valve.

    I figured it may be overheating so I relocated the router and controller inside. The same problem happened again after I moved it inside. It works fine after cycling the power, then when it switches to the next valve, it stops working.

    Can someone please point me in the right direction on what I need to do to fix this. Our yards are beginning to suffer from it and I don’t want our plants to die.

    Before mounting it inside, I took the board out and inspected everything and it still looks as good as the day I put it together a few months ago. Again, any help is greatly appreciate.

    One thought – could the Triacs be bad?

    Thank you,




    I have been trying to troubleshoot it and this is what I have so far:

    I ran a run once program and set each of the 4 stations for 2 minutes.

    Test 1
    Station 1: Good
    Station 2: Bad – after about 30 seconds is when the text on the display went out
    Station 3: Not ran

    Test 2
    Station 1: Skipped
    Station 2: Same results as test one – Bad

    Test 3
    Station 1: Skipped
    Station 2: Skipped
    Station 3: Good
    Station 4: Good

    Test 4
    Station 1: Moved wire to station 2
    Station 2: Good using wire from station one (possibly a bad solenoid?)
    Station 3: Good
    Station 4: not ran – I stopped the test

    Test 5
    Station 1: Failed using wire from station 2

    Test 6 (outside)
    Station 1 Solenoid disconnected
    Station 2 Solenoid Connected to Station 1 wire: Failed after about 1 minute

    Test 7
    Station 1 Solenoid connected to Station 2 wire: Passed

    So after all this work and relocating the router and OpenSprinkler Controller, plus wiring inside the house, it appears to be a bad solenoid causing the Controller to shutdown for some reason. Off to Lowe’s I go. I’ll post up again once I get it replaced and test everything.

    For what it’s worth for anyone who may be experiencing this in hot climates, I would go through similar procedures as above before relocating everything inside…unless you were wanting to do that anyhow to protect the electronics from the heat.



    I would suggest reading the topic “Add MOV to 26VAC input Pins? “. Then try jumpering out the PTC fuse. I know that some of these poly fuses are temperature sensitive and some of them can take days to fully reset. I know, people are going to call “bullSh*t” on the ‘days to reset’ statement. However, this time lag was documented in the poly fuses used in other devices, like the Raspberry Pi.

    My theory is that the large “pull-in” current what the changing stations is what is tipping the poly fuse over the limit.



    Thanks for the info! I installed a new solenoid yesterday afternoon and the timer finally ran through a complete cycle without locking up. I have no clue how long it had been since the last time it ran, but it was long enough that I may have to replace some plants. Hopefully the sage will come back though.

    The pull-in current makes sense as to what was causing the PTC to trip every time station 2 tried to start up. I am going to look into your suggestion for the MOV. I don’t think the problem I was having was related to power surges, but at least it is something to add an additional layer of protection.

    Thanks again…another cycle ran this morning and no issues 😀

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions Locks up when changing stations