OpenSprinkler Forums Hardware Questions OpenSprinkler Beagle (OSBo) Main Program Not Running

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #37285

    mnmsrt8
    Participant

    I have a couple of programs, but one being my Main Program.  It’s the one set to run on odd days, with the weather adjustment.

    It very well could be a configuration issue, but the program just isn’t starting.

    Settings:

    Main Program

    Enable – Checked

    Use Weather – Checked

    Start time – Sunrise + 2om

    Type:

    Weekly – All 7 days

    Restrictions – Odd days

    Stations – All set to 20m

    Additional Start Times

    Repeat Every – 0

    Repeat Count – 0

    App Version – 1.4.2

    Hardware Version: OSBo

    Firmware: 2.1.3

     

    I am not entirely sure what else to give you for information.  Let me know, and I will gladly get any log you would like.

    Also, a feature request.  If a program that includes Weather Adjustment is run manually, it would nice to have the option of you would like to adhere to the adjustment, or ignore it.

     

    #37330

    Ray
    Keymaster

    Not sure when you checked out firmware 2.1.3, but it had a bug which causes the scheduler to not run if the OpenSprinkler app or web interface is closed. Can you do a git pull to update to the most recent version and try again?

    #37341

    Ray
    Keymaster

    By the way, since you’ve set your program’s start time based on the sunrise time — you should first check if the controller is getting the correct sunrise time. You can click the weather icon on the homepage, and the first sunriset time (i.e. today’s) is the one that the controller receives. If it looks incorrect, you may want to check if you’ve set your location correctly. The firmware queries the cloud server to obtain sunrise / sunset times, so another possibility is that for some reason it’s not getting the query result back.

    #37349

    mnmsrt8
    Participant

    I did a git pull almost immediately after I posted.  It did update.  Although, the main program did not run this morning.

    Sunrise is being pulled correctly, as is the timezone.   The timezone and date is also set correctly in Ubuntu using NTP.  Under weather control, my wunderground key works is working correctly as I can log into my account their and see the requests.

     

    I am going to delete the main program, and recreate it to see what happens.

    edit: I just deleted and recreated the program.  Under the program preview it show it will run tomorrow at the sunrise-offset time.

    • This reply was modified 4 years, 6 months ago by mnmsrt8.
    #37367

    mnmsrt8
    Participant

    The program did not start again this morning.  Although, this is a little different circumstance.  My normal times are 20 minutes per zone, and the weather adjustment was at 4%.  So, the time would have been less than a minute.  Nothing was in the log, and nothing ran.

    I pulled out my phone while I was eating my cereal and put in a manual program for 5 minutes a zone, and hit go.  This was using Google Chrome on iOS.  I closed out the browser and continued to eat.  I looked up, and about 8 minutes had gone by and my first zone was still on.  I opened the web browser again and zone 1 immediatley shut down, and zone 2 started with 2 minutes left on the clock.  So I closed the browser and watched.  The zone continued to run, until I opened the web browser again, then the zones switched.

    It seems like all the timing and signals are being sent via the client, and not queued on the OpenSprinkler controller, or somehow cached.

    I am going to tar up the current install and reinstall.  The git pull wasn’t getting me to 2.1.4 from 2.1.3.  I will redownload and resetup everything to see if it helps.

    • This reply was modified 4 years, 6 months ago by mnmsrt8.
    #37369

    mnmsrt8
    Participant

    Okay, so I moved the current install dir to a tarball and recloned the program.  This gave me a fresh start on 2.1.4.

    Everything resetup fine, as expected.  The new unified installer is awesome.

    I am remote right now (at work) and wanted to test it out.  I ran the test all station program, 1 minute a zone from my phone and then closed the browser.  Since I have remote access to the OSBO, I ran a tail -f on todays log.  All the zones cycled (in the log) as they should have on the minute mark.  If it was in the log, I can only assume that the zones switched correctly.

    Sadly, it is supposed to rain for the next couple of days, so I wont see the system start on, but it should at least log a rain delay.

    I am very optimisitic that the re install of the software fixed the issue.

    #37397

    Ray
    Keymaster

    If you want to quickly test, you don’t need to wait till the next day morning, you can create a new program with a start time that’s a minute after the current time, that would allow you to see if the program will run in the next minute or two. If that works, the main program should work too (unless if that program is disabled).

    #37412

    mnmsrt8
    Participant

    Oh yea…duh.  That makes sense.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Beagle (OSBo) Main Program Not Running