OpenSprinkler Forums Hardware Questions OpenSprinkler Beagle (OSBo) New install of OSB0 V1.1 – some challenges

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #23184


    The first step was to flash the recommended unbuntu image onto the eMMC of the BBB (rev A5A). This could not happen as the instructions suggested – I twice did a cold start power up while holding S2 and while I would get the line of LEDS solid after a few seconds, it never finished. Tried 3 more times od varying waiting times – maybe it was this particular BBB. I finally decided to manually install from the SD card using the instructions from

    Use the image which can be directly flashed to the onboard eMMC memory while system is booted from your microSD card (you do it directly on your BBB).

    You can get one from Robert C. Nelson site or ARMhf website :

    sudo wget
    Install it to the internal BBB’s eMMC memory:

    sudo xz -cd BBB-eMMC-flasher-debian-7.5-2014-05-15-2gb.img.xz > /dev/mmcblk1
    Power down your BBB, remove the microSD card and start your BBB again. It will now boot directly from onboard eMMC.

    sudo shutdown -hP now

    Was now able to boot the ubuntu image!

    Wireless strangeness: After installing the recommended Edimax dongle and editing /etc/network/interfaces with my wfi ssid and passcode, I rebooted and got no connection. Looking through dmseg entries, I saw where this ubuntu had reassigned wlan0 to wlan1…no idea why, but I just changes /etc/network/interfaces to select wlan1 instead of wlan0, rebooted and had wifi working.

    setting the rtc: Following the instructions at the wiki for setup BBB (, I first ran into a simple problem.

    sudo apt-get update; apt-get install ntp watchdog fail2ban

    should be

    sudo apt-get update; sudo apt-get install ntp watchdog fail2ban

    (note the sudo for the second command on that line)

    next, I got an error from entering this as recommended:

    sudo echo ds1307 0x68 > /sys/class/i2c-adapter/i2c-1/new_device

    -bash: /sys/class/i2c-adapter/i2c-1/new_device: Permission denied

    I tried changing permissions but kept getting the same error. I can’t go any further on the rtc until I figure this out.

    I went on to configure the the stations via the web page at :8080. I added two expansion zones and renamed all the stations. In setting up the system options, I had changed the location from blank to my town & state (City, State) when I saved them I got an error:

    internal server error

    So I rebooted – still getting internal server error. Now I’m going to have to reload the interval program I fear.

    BTW – I am “upgrading” from the raspberry pi version (stations would fail to trigger). That was great while it worked (~18 months) but I was hoping to use my rain sensor so I ordered this as a replacement.

    I’ll post a follow-up if I discover anything useful.



    What is the easiest way to reset or re-install the interval program to it’s initial state? I can’t get past the “internal server error.”



    I figured out how to reload the OSPi directory. I have narrowed down the “crash” – when I rename the stations, it crashes. I’ve attached image of the stations I named (I tried it several times with blanks between the words, and then the last time with underscores between words – same effect).

    I can operate stations manually without naming them. I’ll try entering a program next.

    What is going on with station naming – this is the same names I used on the Pi version OSPi versus this BBB?



    By the way, I tried to Flash the OS image to another BBB thinking that maybe the first one was having troubles flashing…both boards had the same response – the image did not flash.

    This is a major pain – is there a way I can help troubleshoot this so it can get fixed?



    If you go to the OSPi/ folder under home directory, you can do a ‘git pull’ to update your software to the latest version. I think I’ve heard about the bug that editing station name causes the software to crash, but I assume it has been fixed in the latest version.



    Bug still exists in latest version.



    I looked closer and found that git pull had an error:

     sudo git pull
    Updating e6754ec..ed45985
    error: Your local changes to the following files would be overwritten by merge:
    Please, commit your changes or stash them before you can merge.

    I killed the task, but still get the error – any thoughts on how to correct the error and truly upgrade the app?

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Beagle (OSBo) New install of OSB0 V1.1 – some challenges