OpenSprinkler Forums OpenSprinkler Unified Firmware No webserver after power outage

This topic contains 3 replies, has 1 voice, and was last updated by  themaninspain 2 weeks, 4 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #62675

    themaninspain
    Participant

    My OSPi suffered a power outage today. After reconnecting power I can no longer access the OpenSprinkler web page. I get a connection refused message.

    Looking at the list of ports with netstat there is no process listening on port 8080

    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 0.0.0.0:ssh 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:smtp 0.0.0.0:* LISTEN
    udp 0 0 0.0.0.0:mdns 0.0.0.0:*
    udp 0 0 0.0.0.0:53231 0.0.0.0:*
    udp 0 0 0.0.0.0:bootpc 0.0.0.0:*

    running /etc/init.d/OpenSprinkler.sh status gives me this:

    `sudo /etc/init.d/OpenSprinkler.sh status
    ● OpenSprinkler.service – LSB: Open Sprinkler Raspberry Pi
    Loaded: loaded (/etc/init.d/OpenSprinkler.sh; generated)
    Active: active (running) since Sat 2019-09-21 22:45:15 CEST; 8min ago
    Docs: man:systemd-sysv-generator(8)
    Process: 285 ExecStart=/etc/init.d/OpenSprinkler.sh start (code=exited, status=0/SUCCESS)
    Tasks: 2 (limit: 2200)
    Memory: 1.6M
    CGroup: /system.slice/OpenSprinkler.service
    └─352 /home/pi/OpenSprinkler-Firmware/OpenSprinkler

    Sep 21 22:45:15 pisprinkler systemd[1]: Starting LSB: Open Sprinkler Raspberry Pi…
    Sep 21 22:45:15 pisprinkler systemd[1]: Started LSB: Open Sprinkler Raspberry Pi.

    I’ve trawled through all of the log files and cannot see any error messages.

    The OSPi is a month old and I am using a RPi 2 with Raspbian Buster.

    Any suggestions on how I can fix this?

    #62690

    themaninspain
    Participant

    An update:

    I’ve tried a fresh install on a different RPi (Raspbian Lite) and I have the same problem!
    The WebUI is not available and nothing is listening on port 8080.
    So it seems this is not an issue with my OpenSprinkler/RPi

    PS: Is there any way to change the post title to reflect that this is really a non-functioning WebUI and not an issue with a power outage?

    #62707

    themaninspain
    Participant

    OK, I’ve solved the problem.

    When I did the fresh install I immediately updated all of the packages before building OSPi.
    It turns out that there is a package (not yet identified) that interferes with the web UI.
    I did a fresh install of Raspbian, no updates and then built ospi and it now works.

    My mistake was that I had enabled unattended upgrades on my opensprinkler Pi and when it rebooted after the power outage the updates kicked in and I no longer had a working web UI.

    Now all I have to do is find out which package is causing this.

    #62711

    themaninspain
    Participant

    I’ve now identified the errant package, it’s raspberrypi-kernel

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware No webserver after power outage