OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) ospi site can't be reached on port 8080

  • This topic has 7 replies, 5 voices, and was last updated 4 years ago by Ray.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #47845

    kimbhoot
    Participant

    Hi,
    I built a raspberry pi based sprinkler controller using the pre configured SD image a while back. I haven’t used the system in a few years and took it out this week to start using it again. When I first booted up the system, used the installed app on my phone and seems like it connected right away and the app was able to turn on different ports on the relay module. The app said I have a new update available and I clicked on it but it didn’t seem to be doing anything. killed the app and after restarting it, I’m not able to connect to the pi. I scan, I plug in the IP address but no response. I even tried to load the UI on a web browser using port 8080 but no response either. Apache seems to be running and port 80 brings up a page with this “OpenSprinkler Pi (OSPi) Pre-Configured SD Card” in the heading..

    What am I missing? Any help would be appreciated. The OpenSprinkler service seems to be running but UI wouldn’t load.

    #47849

    barnaclewes
    Participant

    Are you trying it on IPv6? The latest OSPi runs on IPv6 exclusively. I tripped over the same issue just last week, and had to resort to reading the code to figure that out.

    By the way, the URL syntax in your browser is http://[IP:V6:add:here]:8080/ just to save you the bother of looking that up too. 🙂

    #47851

    kimbhoot
    Participant

    barnaclewes,
    Are you serious? I would never have thought of that.. Now I’m trying to lookup my IPV6 address but not able to find it. Does it need to be configured on the pi? I ran the command “ip -6 addr” and it returned nothing. ifconfig also doesn’t show any IPV6 info. Would appreciate some more details on the topic.

    Thanks.

    #47856

    kimbhoot
    Participant

    I just re-imaged my SD card using the SD card image.
    In About section, I see the following info:

    App: 1.7.1
    Firmware: 2.1.4

    I understand I need to be on a newer version before I can configure the GPIO ports but I don’t want to get to 2.1.7 yet. How do I update to 2.1.6?
    I really could use some help.

    Thanks.

    #47864

    Tim
    Participant

    Hi all, I’m not sure the IPv6 is the solution, when checking the TCP listening ports, I only have port 80 and 22 open after doing an update. Before the upgrade (Version 2.1.4) ports, 80, 22 and 8080 are listening.

    #47871

    kimbhoot
    Participant

    Got mine working last night. Apparently the documentation is lacking some details and should include the section below.
    by default, IPV6 is disabled on Raspbian or the OS that OSPi uses.
    see here: https://www.raspberrypi.org/forums/viewtopic.php?t=15886

    The documentation should include this critical step (or maybe the update script should do it automatically):
    Add IPV6 module to your OS by doing this: “sudo nano /etc/modules”, add “ipv6” at the end, reboot.
    Restart OpenSprinkler (if it’s not started automatically): sudo /etc/init.d/OpenSprinkler.sh restart

    That’s it.

    #47944

    bjcatlin
    Participant

    I have created an image with the latest version of Raspbian (stretch) which seems to work perfectly with both IPv4 and IPv6. It is loaded up with the latest Unified Firmware, 2.1.7 (moved from /home/pi/OpenSprinklerGen2 to /srv/OpenSprinklerGen2). I’ve tested it on RPI B+, RPI 2, and RPI 3. It has a few other improvements, such as a software watchdog that will restart the OpenSprinkler firmware if it should fail for any reason, plus I’ve added a delay in the startup of Apache so that if OpenSprinkler is changed to listen on port 80, it will take priority over Apache.

    If you would like to give it a test, it is available at the following link:
    http://www.roar-ranch.com/OpenSprinkler/OpenSprinklerPI-4G-2_1_7.7z

    I have also created an image that is set up for the “Official Raspberry Pi 7-inch touchscreen”. This version is designed to use the Pi touchscreen in a vertical position and it displays the OpenSprinkler web interface in a Kiosk (full screen) interface. This is perfect for those who need local control, such as your friendly gardener. Once I get mine completely assembled, I’ll see if I can make a video of it so that people can see what it looks like. If you have a RPI touchscreen, and either a RPI 2 or RPI 3 and want to give it a try, here is the link to that version:
    http://www.roar-ranch.com/OpenSprinkler/OpenSprinklerPI-4G-touchscreen-2_1_7.7z

    Unfortunately, the touchscreen version does not work well on RPI B+ or earlier, due to the single-core processor.

    Anyway, if you try either of these images, please let me know how it works out for you. If it appears to work well, I can submit it to Ray to replace the outdated image on the website now.

    #47957

    Ray
    Keymaster

    Someone mentioned that “The latest OSPi runs on IPv6 exclusively” — this is NOT correct — the firmware creates dual IPv4 and IPv6 ports, so it should work with either IPv4 or IPv6.

    The only issue we are aware of is users who installed OSPi firmware originally by using the pre-configured SD card image that we created a couple years back. The Raspbian system on that SD card image is out-dated and can’t support dual IPv4 and IPv6. We will update the instructions to remove the pre-configured SD card image. But the solution is to install the latest Raspbian and then install OpenSprinkler firmware according to:
    https://openthings.freshdesk.com/support/solutions/articles/5000631599-installing-and-updating-the-unified-firmware

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) ospi site can't be reached on port 8080