OpenSprinkler Forums OpenSprinkler Mobile and Web App OSPi stopped watering – how to diagnose?

This topic contains 2 replies, has 1 voice, and was last updated by  bdl42 1 week, 5 days ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #62517

    bdl42
    Participant

    Don’t know if the following are relevant or not.
    1. Updated to Android 10
    2. App Version 2.0.3, Firmware: 2.1.6 (1), HW Version: OSPi -AC
    3. Have Zone extender module, Using 16 zones total right now.
    4. Update to Android 10 wiped my configuration from the App. Furthermore, there was no way in the App to load an internally saved setup. Fortunately, I had emailed myself one of my setup configurations and updated my system. All my photos of the zones were gone. That’s just plain annoying.
    5. No rain sensor connected (dead battery) or configured. Have a new sensor. No point of installing until system is functional again.

    No zones work seem to work. Previously, (in Android 9) they all worked. This system has watering my lawn and garden for more than 2 years.
    I went to RPi itself – it has power (26VAC) and the red light is on. If I turn on a zone, say zone 1, then I would expect to measure what voltage between zone 1 and common? 26VAC or so? I get 5mV between all zones and common no matter what zone I energize. I’m kind of irritated as we have just recently planted some fairly large trees, and I thought they were being watered. I need to get this fixed, as I also put in some new sod.

    What can I check for? Is there an internal fuse? (I haven’t opened up the box in a year or so…)
    The RPi2B was last updated 8/30/19 (apt update upgrade). I just updated it now.

    Most of the time, the OSPi has been trouble free. It’s really an awesome gizmo.

    Help me diagnose (and fix) this.
    Thanks!

    #62529

    bdl42
    Participant

    I read updating the firmware, section A.6 and there is nothing strange in /etc/modules

    $ cat /etc/modules
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.
    
    i2c-dev
    
    $ uname -a
    Linux sprinkler01 4.19.57-v7+ #1244 SMP Thu Jul 4 18:45:25 BST 2019 armv7l GNU/Linux
    

    Still no watering 🙁
    There is water in the lines. If you manually twist the valve, the zones water. But there is no electrical control via OSPi.

    #62530

    bdl42
    Participant

    Created a ticket.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Mobile and Web App OSPi stopped watering – how to diagnose?