Tagged: , ,

This topic contains 3 replies, has 1 voice, and was last updated by  mattsplat 4 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #37495

    mattsplat
    Participant

    Got the last v2.2u DIY kit from MicroCenter.  Assembled the board, the picture for the battery holder was the opposite orientation from my silk screen, but I saw another thread on it and went with the silk screened direction.  Tested for resistance, Vin and Vcc showed in the range of 2-5k, sounded lowish but the instructions said over 500, so I kept on.  Plugged in 24Vac to test for voltage – I’m using the transformer from an existing controller, it showed ~27.5V unloaded but only ~20V when connected to the OS, again thought this odd.  Vin and Vcc show nothing, probably due to the low voltage.  Will try a new transformer next (what is the required/recommended amperage btw?  Home Depot has one with 650mA @ 25.5V, didn’t know if this would work).

    Here’s where I’m concerned though.  Plugged it into USB, it boots up, gets an ethernet connection, I’m able to log into the web interface, change settings, update location and time, etc.  The power switch seems to have no effect though, it powers up regardless of whether it’s up or down –  is that normal over USB?  I try updating the firmware and though it will detect the controller as v2.2, it resets when I try to upload it and shows “upload failed”.  It also resets when I do the detection.

    What gives?  Any thoughts appreciated.

    EDIT: Vin shows 4.86V and Vcc shows 3.25V when connected via USB, if that helps at all.  Also checked the lithium battery, 3.29V unloaded.

    • This topic was modified 4 years, 3 months ago by  mattsplat.
    • This topic was modified 4 years, 3 months ago by  mattsplat.
    #37499

    mattsplat
    Participant

    Works on 24Vac on another transformer – powers on, switches on/off, etc.  I read you’re not supposed to connect 24Vac and USB at the same time, otherwise I’d try it for the FW update …

    #37500

    mattsplat
    Participant

    More details!

    Saw the reference to a log file, here it is:

    ====== Fri May 8 10:44:12 2015 ======

    avrdude: AVR device initialized and ready to accept instructions

    avrdude: Device signature = 0x1e960a

    avrdude: Expected signature for ATMEGA644 is 1E 96 09

    avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed

    To disable this feature, specify the -D option.

    avrdude: erasing chip

    avrdude: reading input file “./Firmwares/OpenSprinkler_v2.2/firmware2.1.4.hex”

    avrdude: input file ./Firmwares/OpenSprinkler_v2.2/firmware2.1.4.hex auto detected as invalid format

    avrdude: invalid input file format: -1

    avrdude: write to file ‘./Firmwares/OpenSprinkler_v2.2/firmware2.1.4.hex’ failed

    avrdude done.  Thank you.

    ====== Fri May 8 10:44:12 2015 ======
    Error uploading firmware.

     

    Since it was giving “invalid file format” for 2.1.4 I tried uploading 2.1.3 and it worked!  So, doesn’t look like there’s any kind of power/assembly issue at this point, more of a software issue.  Assuming no further issues someone might want to move this to the firmware forum.

    #37502

    mattsplat
    Participant

    Deleted the 2.1.4 file, redownloaded firmware, tried upload of 2.1.4 again and it worked!  All this nonsense over a bad file, sheesh.  My apologies to anyone that reads this.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.