OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) pre-configured SD card image

Viewing 25 posts - 1 through 25 (of 26 total)
  • Author
    Posts
  • #40572

    Datamonkey
    Participant

    I had a early version of OSPi running for a over a year now.
    I decided to update it when I had to change my network up when I got a new router. I decided to use the pre-configured SD card image. I guessing it is a more stripped down version than the one I originally loaded.
    My problem is setting up the WIFI. I followed the instructions and plugged my Pi into my network, got an IP but when I try to got to http://x.x.x.x and see the ” see a welcome page with further instructions” I get it is unreachable. I can go to http://x.x.x.x:8080 and see the open sprinkler program.
    From the instructions I guessing at http://x.x.x.x there is a way to set up WIFI but I not seeing anything else on it.
    I am just wondering if I am just not looking at the right thing or I messed up the SD install. OR is there a way when I log in to the Pi it self? In the past I used LXDE to do the set up but with this image I can’t get it to run.
    I have a TPLINK TL-WN725N that is working fine.
    Can anyone tell me where I went wrong?

    #40585

    Ray
    Keymaster

    Can you ssh to RPi? If so, the page that’s supposed to be shown when you access http://x.x.x.x is just the index.html file under /var/www/html

    #40610

    Datamonkey
    Participant

    Yes I can SSH in using Putty.
    I can’t view the file because as far as I can tell there is not text reader on the image. So I am not sure what is in the index.html file.
    I did some reading and tried setting up my WIFI via the command line but it can’t see the TPLINK TL-WN725N. It is saying:

    p[email protected] ~ $ ifconfig wlan0 up
    wlan0: ERROR while getting interface flags: No such device

    I thought this dongle from what I read and in the past that it should load automatically for Raspberry. It was also working before switching to the image.
    I guess what my issue is I am not a command line guy and was used to using Xwindows or something like that to do all my set up in the past. So I am stumbling through with this command line setup.

    But as long as I am connected via CAT5 I can get to http://x.x.x.x:8080 no problem (Much improvement from the version I was running.) but not http://x.x.x.x/.
    If there is nothing on http://x.x.x.x/ that I need for WIFI setup then I will try doing via command line.

    Can some one validate if a TPLINK TL-WN725N need drivers installed in this image? Or am I just a completer idiot and I totally going about this wrong.

    #40644

    Ray
    Keymaster

    In Linux, you can view the content of a file via ‘cat’, ‘vim’ or other text editors you prefer.

    The instructions about setting up WiFi are the same as how you set up WiFi in general for RPi — there is nothing at http://x.x.x.x/ about WiFi that’s special. I really don’t think you need to read that page in order to set up WiFi.

    #40854

    Datamonkey
    Participant

    I was out of town for a few and had enough time over the long holiday to try this again.
    I tested the TPLINK TL-WN725N and it is working fine.
    I downloaded a fresh copy of the pre-configured SD card image using SD Formatter on my SD card and Win32 Disk Imager to make the SD card. No problems there.

    Now once I hook up the Pi to my network and boot it up I get to the static IP I assigned it (http://192.168.1.169/ Localy by MAC address) and do the following from the instruction on your PDF:

    Next, open a browser, and type in http://ospi_ip/ where ospi_ip is the RPi’s IP address (such as http://192.168.x.x). You should see a welcome page with further instructions. If you see this page, congratulations, the image is successfully burned onto your SD card.

    When going to http://192.168.1.169/ using my Win box via IE I get the following:

    This page can’t be displayed

    •Make sure the web address http://192.168.1.169 is correct.
    •Look for the page with your search engine.
    •Refresh the page in a few minutes.

    Also see the attachment as you can see the Open Sprinkler icon in the URL line. So I assuming I getting to the right place but I do not get the welcome message. I know you said there is nothing there that I need to but I wondering is the Apache server is not loading correct as I do see an error about setting it to and IP of 127.0.1.1 during the Pi’s boot up.

    Besides the Apache error I am also thinking that the drivers for the TPLINK TL-WN725N are not in the image as when I do Ifconfig it never pops up as an option to config. I just see the ethernet.

    As I am not a Linux guy and I tried using a bunch of 3rd party web pages on commands to try to figure this out . I think if I can get the WiFi working the rest will fall in to place but guess I am at a loss on how to do it because the pre-configured SD card image seems to be a stripped down version as may of the 3rd party tips for setting this up are not there. Or I am just not bright enough to get it.

    I guess I looking for someone to hold my hand as I am not used to working in this OS.

    Attachments:
    #40923

    Ray
    Keymaster

    The pre-configured SD card image includes drivers for a small number of popular WiFi dongles. But since the image was made a while back, it doesn’t have drivers for newer dongles. Here are two suggestions:

    1. Change the WiFi dongle, for example, to the popular Edimax one:
    http://www.amazon.com/Edimax-EW-7811Un-150Mbps-Raspberry-Supports/dp/B003MTTJOY
    which is well-supported by RPi our of box.

    2. If you don’t want to change the dongle, you can start with a RPi image that works with your dongle (or has driver for it), then install the OpenSprinkler Unified Firmware yourself, by following the instructions here:
    https://opensprinkler.freshdesk.com/solution/articles/5000631599-installing-and-updating-the-unified-firmware#install

    #41250

    sakos
    Participant

    Sorry for double posting but I would like to comment here as well, that I installedd the latest OSPi SD Card Image 2 (with Unified Firmware, update 05/31/15) but it will not work on Raspberry Pi Zero. I could not test but presumably it won’t work with other Model A/B either since they have the same platform as Zero.
    The green LED is blinking but no output on the HDMI port.

    #41267

    Ray
    Keymaster

    You are right: since RPi zero came out very recently, the SD card image does not work for Zero. However, it’s very easy to install firmware yourself from a fresh Raspbian installation. Just a matter to running three commands:
    https://opensprinkler.freshdesk.com/solution/articles/5000631599-installing-and-updating-the-unified-firmware#install

    #41269

    sakos
    Participant

    Thanks Ray,

    I assumed that the pre-configured SD card contains other settings, tunigs, etc which are needed for OSPI to run smoothly. Then I will install according to your suggestion.

    #41327

    sakos
    Participant

    Hi Ray,

    I am struggling with installing OSPI from scratch. Unfortunately it is not so simple. I got stuck with configuring the RTC.

    – Following devices are added to /etc/modules
    snd-bcm2835
    i2c-bcm2708
    i2c-dev
    rtc-1307

    – dtparam=i2c_arm=on is enabled in /boot/config.txt

    However the hwclock is not accessible. I got this:

    [email protected]:~ $ sudo hwclock --debug
    hwclock from util-linux 2.25.2
    hwclock: cannot open /dev/rtc: No such file or directory
    No usable clock interface found.
    hwclock: Cannot access the Hardware Clock via any known method.

    It works fine on the old image with the same settings. I assume that something more is missing from the configuration.

    #41352

    Ray
    Keymaster

    Unless if you absolutely need it, there is no need to configure the RTC for now — as long as RPi is online, it will obtain current time from the network. RTC is needed if your RPi is offline or doesn’t have Internet connection.

    #41383

    sakos
    Participant

    Yes, I think RTC is needed for reliable operation. I have found out the solution by myself.
    If anyone is interested hereby I share my SD card image. It has some extra features.

    – Based on latest Raspbian Jessie Lite

    – Supports Raspberry Pi Zero

    – Easier wifi configuration
    You do not need a wired LAN connection to configure wifi. The wifi configuration file is moved to FAT partititon accessible by Windows.
    Just write the image on an SD card then open in a file manager and edit the wpasupplicant configuration file directly.
    If your wifi stick is supported by default then Pi will automatically connect to your wifi network after power up.

    – Raspberry on board watchdog is activated and handled by OSPI software for higher reliability
    If OSPI software gets stuck for more than 15 sec then Raspberry will restart. The operation can be tested by issuing this command:
    sudo /etc/init.d/OpenSprinkler.sh stop

    – Control of relay on legacy Opensprinkler Pi boards.
    To assign the relay to a station just configure the station as “RF” and set “0” as RF code.

    – 1s resolution of timers
    If you set the timer value by directly input numbers instead of using +/- signs then 1 sec resolution is accepted and stored at any long intervals

    – Scheduled adjustments and update of RTC.
    Maintainment of RTC

    Instructions:
    Download, unzip and write the image to an SD card. You can use win32diskimager tool for writing. Minimum SD card size is 2GB.
    MD5 hash: 4094777bcf7577c56626a93eff32da8e
    Open the SD card in the file browser and edit the wpa_supplicant.conf file
    You have to edit the SSID and Wifi PSK then save the file

    #41398

    Ray
    Keymaster

    OK. Thanks a lot for sharing. Will check it out and perhaps should probably use yours to replace the current one in the user manual.

    #41402

    sakos
    Participant

    Ok with me.
    Please be aware that this image has some changes in the source code in comparision with latest version on github.
    In case of including it in the documentation please make a copy of the image on storage space under your control.

    How can I send you a PM?

    #41446

    Ray
    Keymaster

    Not sure about PM in the forum. But you can send an email to [email protected]

    #41473

    dsell
    Participant

    Wish I had seen this earlier this week. I built an OpenSprinkler 1.2u unit years ago and its been in service ever since. I wanted to give the OSPI a shot and found one on EBay with a Pi Zero!

    Used Ray’s Pi image from last year and did a sudo apt-get upgrade to get the image to work with the Pi Zero. Works great, although if I didn’t have other Raspberry Pi PCs around the WiFi config would have been much easier with Sakos’ image.

    I think I might try this image just for the heck of it.

    -David

    #42235

    Csaba Toth
    Participant

    @sakos
    Szép Napot!
    I see you are quite advanced in the Ospi install and use.
    I am struggling for 2 weeks it is working, but I stuck at more and more traps.
    I am just downloading and imaging your OSPI_216 version, I am quite interested.

    If you don’t mind I would contact you in PM -in Hungarian- if possible. Pls. send your email to <my_forum_name>@freemail.hu

    Thanks, Csaba

    #42309

    Csaba Toth
    Participant

    I have downloaded the image, but I can’t setup the wifi.

    If I setup the Pi-Zero from Noobs, and install the firmware and setup the wifi according to this link, it works: http://www.instructables.com/id/How-to-give-an-internet-access-to-Raspberry-Pi-Zer/step4/Solution-4.
    It is absolutely needed for the wifi to work.

    The downloaded SDimage can’t be upgraded and updated according to the link.

    Thanks.

    #42417

    Ray
    Keymaster

    Well, I have to update the pre-configured SD card image soon. Honestly, given the speed RPi image updates, and how fast they are releasing new versions of RPi, it’s probably better to just use an existing RPi image that already works, and follow the instructions here to install the OSPi firmware:
    https://opensprinkler.freshdesk.com/solution/articles/5000631599-installing-and-updating-the-unified-firmware
    it’s just a matter of running a few command lines.

    #43019

    skydivingcat
    Participant

    Sakos

    Does this image still work?

    #43445

    skydivingcat
    Participant

    Trying to use this image for a controller at work. I get it to work fine while sitting on my desk hooked up to a secure network when I move it to the sprinklerbox I have to connect to a unsecured network and can not get it to connect.

    I changed wpa_supplicant to this.

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1

    # To configure wifi access insert your SSID and PSK with keeping the quotation marks then save the file

    network={
    ssid=”My ssid”
    key_mgmt=none

    }

    What else do I need to change?

    #43447

    Stephen
    Participant

    This works for me here in Australia …

    country=AU

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1

    network={
    ssid=”YourNetworkSSID”
    psk=”YourVerySecretPassword”
    }

    #43452

    skydivingcat
    Participant

    The network I am trying to connect to has no password.

    #43480

    Greenthunder
    Participant

    I’m trying to use this image with a Raspberry PI 3. It doesn’t seem to be booting, and the screen is blank. Is there changes I have to do in the config?

    Thanks,

    #43501

    Ray
    Keymaster
Viewing 25 posts - 1 through 25 (of 26 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) pre-configured SD card image