OpenSprinkler Forums OpenSprinkler Mobile and Web App Problems with Weather Updates ET method

This topic contains 23 replies, has 6 voices, and was last updated by  dun4cheap 1 month, 2 weeks ago.

Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #61965

    Phil Maron
    Participant

    I’m sorry if this has been discussed elsewhere but I have searched and not found any resolution to my issues.

    I recently switched to the ET method from Zimmerman because it seems a more widely accepted method and initially it provided the data however after a few days I noted that the data was not updating. I have tried rebooting but this makes no difference and the last successful update after a reboot simply shows: –. If I switch back to Zimmerman and save and then switch again to ET again it initially provides data but again never updates successfully. Can anyone please help me to troubleshoot as I am at a loss.

    My System is Hardware Version 2.3 – AC running firmware version 2.1.7.
    Thanks in advance

    #61972

    Ray
    Keymaster

    Whether you use Zimmerman or ET, the watering percentage number updates only once a day. Does the number not change over multiple days?

    #61990

    Phil Maron
    Participant

    From what I have seen it does not when set to ET but it definitely does when set to Zimmerman. I have just set the method back to ET as I had reset it to Zimmerman and I noticed that the last call showed an update at the time that I set it but the last successful call was showing as some time earlier. I will monitor it over the next couple of days and reconfirm whether or not it is updating since I was not sure how frequently it is supposed to update. Thanks for the response Ray.

    #62000

    Ray
    Keymaster

    The other thing to make sure if that you have chosen a baseline ETo value. Without baseline ETo, the ET algorithm will return an error hence the numbers will not update.

    #62004

    Phil Maron
    Participant

    Thanks Ray. Yes I had checked this because I read that comment from you elsewhere. Anyway, still no successful weather call since before I set it to ETo. It currently reads Last weather call Sun, 4 Aug 2019 3:24:36 and Last Successful weather call Sat 3 Aug 2019 5:35:12 which is about an hour before I changed over to ETo.

    #62006

    Ray
    Keymaster

    You should check if your weather script is set to point to weather.opensprinkler.com
    Go to http://x.x.x.x/su
    where x.x.x.x is your OpenSprinkler’s IP address. There you can see if the weather script url is correct. Other than this, I really can’t think of any other reason why it gets Zimmerman successfully but not ET.

    #62008

    Phil Maron
    Participant

    Thanks for your help Ray but unfortunately it hasn’t helped. I checked that URL and it does point at weather.opensprinkler.com. Is there nothing else I can check?

    #62010

    Phil Maron
    Participant

    OK, just an update. I decided it was probably worth giving the unit a factory reset to see if that would make any difference. After doing that I restored the settings from a backup and found that there was no change. I then reset to factory default a second time but this time I re-entered all of my settings manually. So far from what I can see it’s all working. If I reboot the unit it seems it will always make a weather call and at this stage that always seems to be successful. I will monitor it for a few days and see how it goes.

    Importantly, I should point out that before doing a factory reset I noted that I was actually having the same issue with the Zimmerman method. On further testing I suspect that caching of my web browser (Google Chrome) is likely to have distorted my findings because unless I force a re-read of the page, I can’t always see updates. I first discovered this when trying to manually enter settings. After saving my changes I would go back and look at them and find that they appeared not to have changed but after forcing a refresh, the setting had in fact changed.

    #62096

    cody.hargreaves
    Participant

    Im having similar trouble. I set my weather adjustment to ET a couple weeks ago when this update came out. My watering percentage was initially set to 137% and has not changed sense. While that setting is decent for this time of year, I’d assume it would change a little. We’ve had some days of heavy rain, and some really hot days.

    #62100

    cody.hargreaves
    Participant

    I changed my weather adjustment to Zimmerman and it immediately changed the watering % to 63%. Now it shows a last successful weather call. Changed back to ET and no change. Still at 63%

    #62115

    Phil Maron
    Participant

    This sounds a bit like what was happening to me but it was a bit confused because I found out half way through that my browser at times needed a forced refresh of the page for me to see the current setting. Anyway, I know it seems drastic but since performing a factory reset and recreating all of my stations and programs it all works as it should. Not a nice solution but it’s the one that I found resolves the issue.

    #62288

    Mattinger
    Participant

    Hello,
    I can confirm that my system does not change the watering percentage when using ET method. Using the Zimmerman method works fine.

    Regards,
    Matthias

    #62295

    cody.hargreaves
    Participant

    I did a complete factory reset and re-programmed everything as Phil suggested. That fixed the issue for me and ET is now working. Updates every morning.

    #62328

    spanno
    Participant

    I have the same problem, stuck at a steady 110%, even after a full day of rain.
    Switching between Zimmermnan and ET back and forth forces a manual update of ET, but no automatic, daily update.
    I can confirm that weather script is set to point to weather.opensprinkler.com.

    When I have time, I will go the factory reset route, or is there any indication this issue might be solved through a software update?

    (the question being: are all users affected, or only the ones with a funky setup (mine being pretty straightforward, un-funky), and what would be the common denominator for the affected systems? – but perhaps that is too much hassle to figure out, and heck, what is more fun than reprogramming your sprinkler setup? ;))

    • This reply was modified 1 month, 2 weeks ago by  spanno. Reason: notify for followup
    #62331

    Ray
    Keymaster

    I suspect this may have to do with weather adjustment option not being correct. To check that variable, you can use either of the following method:
    1. access your controller in a web browser, then open the browser’s ‘developer tools’ panel (in Chrome, this would be under menu More Tools -> Developer Tools), turn on the ‘Network’ tab, refresh the page, then check the result of the ‘ja’ query.

    2. alternatively, you can also directly type in:
    http://x.x.x.x/ja?pw=yyy
    where x.x.x.x is your OpenSprinkler’s IP address and yyy is the md5 checksum of your password.

    Either way, the result of ja will have a group called ‘settings’ which in turn contains ‘wto’. You can check what is its value and paste it here. If you are using ET, it should at least contain baseETo and elevation. Otherwise if it doesn’t contain these variables then it could explain why it’s not updating.

    #62332

    spanno
    Participant

    Yep, does contain data (shown below) and ja? seems to run about every 2-3 seconds

    wto: {baseETo: 0.16, elevation: 246, h: 100, t: 100, r: 100, bh: 40, bt: 69.98, br: 0}
    baseETo: 0.16
    bh: 40
    br: 0
    bt: 69.98
    elevation: 246
    h: 100
    r: 100
    t: 100

    One remark: These data shown here are in inches/feet, However, I use the metric option in /Options/System

    • This reply was modified 1 month, 2 weeks ago by  spanno.
    #62335

    Ray
    Keymaster

    The unit isn’t a problem because the app internally uses imperial units, and change between that vs. metric only affects the display. So if you are querying the internal parameters it will all be in imperial units. With the current firmware it unfortunately does not record error from the weather call and relay that to the app. We are getting close to release the next firmware 2.1.9, which has added the capability of storing weather call error, so when that’s ready, you will be able to find out why the watering percentage is not updating. At the moment I think the best option is probably to save a copy of your configurations, do factory reset, then import your saved configurations again. It still takes some steps, but you won’t have to reconfigure everything from scratch.

    #62349

    Ray
    Keymaster

    By the way, I should also ask you about the ‘Location’ — the ET algorithm does NOT work with pws location names, so if you happen to set your location to a pws, that won’t work. In the /ja result, you can check the variable named ‘loc’, it should be a GPS coordinate. In fact, you can submit a support ticket and attach the entire result of /ja, so that we can check to see if there is something wrong with the configurations.

    The /ja result is the same as if you export your configurations. So you can also just export configurations to a file and attach it to your support ticket.

    #62354

    spanno
    Participant

    @ray,

    OK, here is the output from /ja/settings/loc:

    loc: “40.81050,0.45852”

    doesnt seem to be a pws location name, I am sorry…

    settings: {devt: 1566850462, nbrd: 2, en: 1, rd: 0, rs: 0, rdst: 0, loc: “40.81050,0.45852”, wtkey: “”,…}
    RSSI: -65
    curr: 0
    devt: 1566850462
    eip: 1602354689
    en: 1
    ifkey: “”
    loc: “40.81050,0.45852”
    lrun: [2, 2, 3300, 1566712501]
    lswc: 0
    lupt: 1566646945
    lwc: 1566848605
    nbrd: 2
    ps: [[0, 0, 0], [0, 0, 0], [0, 0, 0], [0, 0, 0], [0, 0, 0], [0, 0, 0], [0, 0, 0], [0, 0, 0], [0, 0, 0],…]
    rd: 0
    rdst: 0
    rs: 0
    sbits: [0, 0, 0]
    sunrise: 437
    sunset: 1247
    wtkey: “”

    If you prefer the entire output attached to a support ticket, let me know, and also, what is the best way to grab the entire /ja output? (for now I’m using google Chrome, as suggested.

    hope this helps!

    #62355

    Ray
    Keymaster

    Yes it would help to know the entire configuration, for example, firmware version, minor revision etc.

    #62370

    spanno
    Participant

    @ray

    OK, here is as much info as I can provide:

    settings file:

    {“settings”:{“devt”:1566850792,”nbrd”:2,”en”:1,”rd”:0,”rs”:0,”rdst”:0,”loc”:”40.81050,0.45852″,”wtkey”:””,”sunrise”:437,”sunset”:1247,”eip”:1602354689,”lwc”:1566848605,”lswc”:0,”lupt”:1566646945,”lrun”:[2,2,3300,1566712501],”curr”:0,”sbits”:[0,0,0],”ps”:[[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0],[0,0,0]],”wto”:{“baseETo”:0.16,”elevation”:246,”h”:100,”t”:100,”r”:100,”bh”:40,”bt”:69.98,”br”:0},”ifkey”:””,”RSSI”:-65},”programs”:{“nprogs”:2,”nboards”:2,”mnp”:35,”mnst”:4,”pnsize”:16,”pd”:[[113,1,2,[297,-1,-1,-1],[0,0,0,0,0,0,0,0,240,0,0,0,0,0,0,0],”pump start progr”],[115,1,2,[300,-1,-1,-1],[0,0,3000,0,0,0,0,0,0,0,0,0,0,0,0,0],”irri moestuin”]]},”options”:{“fwv”:218,”tz”:56,”ntp”:1,”dhcp”:1,”ip1″:192,”ip2″:168,”ip3″:0,”ip4″:111,”gw1″:192,”gw2″:168,”gw3″:0,”gw4″:1,”hp0″:80,”hp1″:0,”hwv”:30,”ext”:1,”sdt”:0,”mas”:1,”mton”:0,”mtof”:0,”urs”:0,”rso”:0,”wl”:110,”den”:1,”ipas”:0,”bst”:320,”uwt”:3,”ntp1″:50,”ntp2″:97,”ntp3″:210,”ntp4″:169,”lg”:1,”mas2″:2,”mton2″:0,”mtof2″:-20,”fwm”:4,”fpr0″:100,”fpr1″:0,”re”:0,”dns1″:8,”dns2″:8,”dns3″:8,”dns4″:8,”sar”:0,”ife”:0,”sn2t”:0,”sn2o”:0,”reset”:0,”dexp”:0,”mexp”:8,”hwt”:220},”status”:{“sn”:[0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0],”nstations”:16},”stations”:{“masop”:[253,123],”ignore_rain”:[0,0],”masop2″:[4,128],”stn_dis”:[0,0],”stn_seq”:[252,56],”stn_spe”:[4,195],”snames”:[“master 1 pomp”,”master 2 ball valves”,”virtual moestuin”,”S04″,”S05″,”S06″,”S07″,”S08″,”pump start advance”,”pump stop delay”,”S11″,”S12″,”S13″,”S14″,”run pump only”,”Open ball valves only”],”maxlen”:24}}

    Firmware 2.1.8 (4)
    Hardware version : 3.0 DC

    Anything else that might help?

    Thanks for your time and attention, so far!!

    #62389

    Ray
    Keymaster

    I think I understand why: your wto, which currently has:
    “baseETo”:0.16,”elevation”:246,”h”:100,”t”:100,”r”:100,”bh”:40,”bt”:69.98,”br”:0
    is quite long. Firmware 2.1.8(4) assumed that wto is no longer than 60 characters: back then we didn’t have ET algorithm so it never came up that wto could be longer than that; also, the UI should not have saved the h, t, r, bh, bt, br parameters as those are irrelevant to ET (those are parameters for Zimmerman). In any case, as a result of the combination of these, when the firmware loads wto, some parts of wto is cut off, causing the query to fail.

    Here is the work-around: first select ‘Auto Rain Delay’ as the adjustment method, set any delay duration you want, submit. Then go back and select ET as the adjustment method, choose baseline ETo, submit again. This should force wto to get rid of the extra parameters that it doesn’t need, and the resulting wto should fit in 60 characters.

    We have addressed this issue in the upcoming firmware 2.1.9 which allows much longer wto string, but also we’ve modified the weather script to avoid saving parameters not needed by each specific adjustment method.

    • This reply was modified 1 month, 2 weeks ago by  Ray.
    • This reply was modified 1 month, 2 weeks ago by  Ray.
    #62398

    spanno
    Participant

    OK, I applied the work around. I can confirm that:
    1) after re-engaging ET the water level percentage was updated
    2) wto entry has been abbreviated to: wto: {baseETo: 0.16, elevation: 246, d: 24}

    So now it seems to work just fine.

    If i run into any hangups with ET not phoning home (yep, had that one coming;), I will post a reply here. If no news, good news!

    And a lot less work then redefining everything. Thanks a lot Ray!

    #62406

    dun4cheap
    Participant

    I was wondering why my controllers had different water percentage. From 53%-98%. I have only moved 3 to eto. 3 different hw versions. 2.2, 2.3 and a 3.0 unit. Anyhow I followed the workaround. Now I am showing 75%, 76%, 76%. The 75% is from a 3.0 unit. It is across the street from the other 2. It must be a little wetter 200 feet away..

Viewing 24 posts - 1 through 24 (of 24 total)

You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Mobile and Web App Problems with Weather Updates ET method