OpenSprinkler Forums OpenSprinkler Unified Firmware Remote Stations not working after Unified Firmware 2.1.7 Update

  • This topic has 13 replies, 4 voices, and was last updated 3 years ago by Ray.
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #44618

    Tim
    Participant

    Hi, after doing the 2.1.7 update my remote stations are no longer triggering on the remote end.

    System 1 has 2 remote stations configured and are triggered by a program from this System
    System 2 (Remote end) has the 2 physical stations hardwired on Station 15 and 16

    The logs show the station running when triggered from System 1, but no activity appears on System 2, and the stations do not physically open.
    If I trigger the stations directly on System 2 they work fine.

    Has anyone else done the update and also use remote stations?

    App Version 1.6.0
    Firmware 2.1.7
    Hardware Version: OSPi-AC

    #44667

    Ray
    Keymaster

    Sorry to hear about that. I will do some testing on the remote station feature to find out.

    One new option that got introduced in firmware 2.1.7 is the ‘Special-station Auto Refresh’ option, which is turned off by default. In firmware 2.1.6, special stations (including remote and RF stations) are automatically refreshed to make sure the remote stations are in sync with the master controller. Due to several requests, we made this an option that you can choose. You can go to Edit Options -> Advanced, turn that flag on, and see if this makes any difference.

    #44708

    Tim
    Participant

    Thanks Ray, turning on “Special-Station Auto Refresh” option fixed the problem.

    On a side note, “System 2” which was configured as “An Extender” before the upgrade. After the upgrade and resorting the config, the System wasn’t automatically re-enabled as an “Extender”. I also couldn’t find the option to turn this back on.??
    The only way I managed to setup “System 2” as an extender again, was to change the Remote station settings configure on “System 1” which then prompted to change “System 2” to an “Extended”

    Cheers

    #44800

    Ray
    Keymaster

    @Tim, regarding how to set the controller as extender, I think you are right that currently the only way is to enable it when you set a station to be ‘remote’ on the master controller. Actually, I am pretty sure you can do so manually by using buttons (see the procedure below). But you are right that other than these, the UI doesn’t present the option to set a controller to ‘remote extension’ mode. I think the reason it didn’t import this option is because changing this option requires using a different command (not the change option command). Anyways, it’s a bug that we can easily fix.

    Most options that are modifiable can be changed manually on the controller using buttons. To do so, power off the controller, then press and hold button B3 while powering the controller back on. Continue holding the button until the LCD displays ‘Setup Options’. Then click B3 to cycle through all options. When you are at a particular option, using B1 or B2 to change its value, and finally when you are done, press and hold B3 until the controller restarts. This is the procedure to change option values using buttons.

    #44819

    Tim
    Participant

    Thanks Ray, only one small problem with the button option. I’m using OSPi-AC hardware and don’t have any.

    Cheers

    #44980

    Ray
    Keymaster

    @Tim, ah, ok, I didn’t realize you are using OSPi. I think at some point we should probably make the configuration file for OSPi an ASCII (human readable) file so that you can directly open it and edit the options. At the moment the configuration is kept as a binary file to maximally share the code with OpenSprinkler,

    #45924

    LeighGr
    Participant

    Thanks Ray and Tim.

    I’ve been puzzling over the same issue. I’ve held off upgrading my two OSPi’s to 2.1.7 until last month, and with having been away on holiday for a few weeks, I only noticed today that the remote zone, which controls the borehole pump, wasn’t working as expected! Setting the “Special Station Auto Refresh” option on the master controller fixed the issue.

    #46113

    Ray
    Keymaster

    I found the source of the issue: firmware 2.1.7 has a bug that when sending remote command when ‘special station auto-refresh’ is turned off, it uses the maximum value 65535, but the manual control command (/cm) only accepts 64800 as the maximum value. Because of this discrepancy, the 65535 value is dropped, causing it to not respond to remote command. Turning on auto-refresh forces it to use a smaller run-time value (and relies on periodic refreshing to renew the command). We will fix this in the firmware as soon as possible.

    #46303

    JacekOrdowski84
    Participant

    Hi Ray

    Can you rush to solve the problem?

    Currently, opensprinklers support my entire farm. My strawberries will be very grateful to you.

    Greetings from Poland

    #46367

    Ray
    Keymaster

    Did you turn on the ‘Special Station Auto-Refresh’ option as I described? That should fix the remote station problem.

    #46413

    JacekOrdowski84
    Participant

    Without the special section, the remote valves are not activated at all. With special section remote valve starts, but only for several seconds.

    I tried changing options in hundreds of ways but without effect.

    What can i do wrong?

    #46699

    Ray
    Keymaster

    If the valve only turns on for several seconds, I suspect you must have some script, or a master controller that’s sending command to the remote valve to turn it off. When auto-refresh is turned on, it will renew the command every 1 minute or so. Even if the renew command was not received, it should at least run for about a minute. If it turns off way before a minute, it’s very likely that something is sending a command to it to turn it off.

    #49389

    JacekOrdowski84
    Participant

    hi Ray.
    I eliminated the problem of switching off the section after a few seconds, the reason was in the controller from another company. But he’s gone and I’m just working on an open sprinkler. However, there are further restrictions, I can activate the special section only for about 1 minute 47 sec. I tried in many configurations with refreshing, no refreshing etc. In the forum # 46113 I read that software 2.17 has a problem is the possibility of repairing this in a simple way, but not for me. I have never done this and I do not know where to start.

    And now the question to you, can you improve the software so that the remote sections function?
    On my farm I use 6 open sprinklers, they manage the irrigation system for about 100 ha, the problem arises when I have to make corrections due to weather conditions or other unforeseen factors. I make changes in the open sprinkler located in the pumping station and then I have to correct everything in the devices located on the plantations. Frequently there are errors due to hurry, in the previous season, as a result of one mistake, I ripped the main irrigation thread.

    I would be very grateful for your help

    Regards Jacek

    #49982

    Ray
    Keymaster

    I read your question three times and I still don’t quite understand specifically how you’d like us to improve the remote station function?

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware Remote Stations not working after Unified Firmware 2.1.7 Update