OpenSprinkler Forums OpenSprinkler Unified Firmware Required Interval Duration

  • This topic has 5 replies, 4 voices, and was last updated 3 years ago by Ray.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #22487

    Samer
    Keymaster

    Hey Ray,

    When I first got the OpenSprinkler the hardest part was understanding the interval setting. It seems this is required and has to be greater than 0 for the program to even run once. In my head, I never wanted it more than once and I kept it at 0 but programs never ran. After reading your documentation closely I realized I need it greater than my program duration for everything to work and indeed thats what I ended up doing. This is the same behavior on the OSPi as well and the program preview properly accounts for this. I was hoping to see if this could be changed in the future to allow an interval of 0 rather than having to check and make sure the interval is greater than the program duration window.

    Thanks!

    #24523

    Ray
    Keymaster

    Ah, that’s a good suggestion and should be easy to address. The reason it does not allow 0 interval time is that the algorithm checks time match by computing:
    if ((current_time – program_start_time) % interval_time == 0)
    and a 0 interval_time would be invalid. But this can be easily addressed by adding a if statement before the checking to see if interval_time = 0.

    I am actually surprised that you can set interval_time to 0: the Javascripts should check the validity of each parameter. Maybe I forgot to check this parameter…

    #24524

    Oleengr
    Participant

    If the INTERVAL referred to above is the INTERVAL that defines the number of days before the program runs again, then I heartily second the motion for allowing an interval of 0 (or 1).

    I was bummed out when I tried to set an interval program from once every two days to once every day, and found I had to switch to a day-of-week program to accomplish it. There is nothing easier than adjusting the interval to achieve seasonal changes, and having to switch gears to a day-of-week type program to achieve it seems unnecessary and very klunky. I believe in my case I got an error message when I changed the interval from 2 to 1. Zero doesn’t seem like it applies in this sense of Interval. Am I referring to the same parameter?

    I was going to write a few weeks ago, but haven’t even had time to even check in and read the posts.
    FWIW, OpenSprinkler is doing just fine in its metal box outside at 108+ degrees in the shade. I removed the plastic cover to give it the maximum convection cooling

    #24525

    Samer
    Keymaster

    @Ray, that is awesome that it could be an easy fix! Also, I am setting it using my web app which is why I am not getting an error about a value of 0. I should probably add that check until a fix is in place.

    Thanks!

    #51384

    samuel.thoraval
    Participant

    On latest installed version, if setting the interval (Days) to 1 it complains it must be set between 2 to and 128 Days…. I don’t understand the logic here. What if I want to run the program every day for 15min at the same time? I can only choose 2 Days which means every 2 days…. ?!

    Cheers,
    Sam

    #51454

    Ray
    Keymaster

    Watering every day is equivalent to select all 7 days of a week. So choose Weekday schedule, and select all 7 days.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware Required Interval Duration