OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Fix for RTC clock not working after firmware update

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #35604

    Toonces
    Participant

    Hi, I am new to OSPi but not to the Raspberry Pi. Needing only the thinnest excuse to buy new hardware, I repurposed my son’s pi after stumbling across an OSPi compatible interface board. 16 stations vs 6 and I can have actual, english understandable programs that don’t involve turning every station on! WooHoo, I’m thereOf course, I had to replace his pi with a pi2 ūüėÄ So I set about yesterday setting things up and after fighting with 3 different USB wifi adapters that wouldn’t stay connected, I updated my firmware to the latest¬†Linux ospi 3.18.7+ #755 PREEMPT Thu Feb 12 17:14:31 GMT 2015 armv6l GNU/Linux version. Between the update and turning off power management, I have rock solid wifi and a nice OSPi system mounted in an ex Orbit 6 station controller box. Since I cannot leave well enough alone, I have updated raspbian, configured my stations, watered the lawn a few too many times and just¬†generally¬†geeked out showing off my cool¬†new¬†internet enabled, phone app having, need to add a camera so I can watch the grass grow sprinkler system to my¬†co workers. ¬†As I went through Ray’s site showing one of my¬†coworkers¬†where they could get such a modern marvel of technology, I ran across the instructions for setting up the RTC. So tonight after I got home from Wireshark class, I set out to have my pi keep things super accurate and failed miserably……

    I’m a Linux admin by profession and can usually follow written instructions (BTW, there’s a typo at line 31 of the rtcdev script. it should be *) not “). On the 1.4 pre-made image, there’s no script to copy so you have to copy and paste which led to the discovery of that issue.

    So after having figured that out I couldn’t figure out why I kept getting errors like “Error: Could not open file /dev/i2c-1' or/dev/i2c/1′: No such file or directory”

    modprobe couldn’t find any i2c devices. I double and triple checked that I had the correct entries. nothing blacklisted, devices added to modules. It was all done and still nothing. Then I ran across this¬†http://www.raspberrypi.org/forums/viewtopic.php?p=675658#p675658

     

    Basically, If you’ve updated your firmware like I have, it’s no longer enough to make the modifications at¬†http://rayshobby.net/mediawiki/index.php/Real_Time_Clock_(RTC)_Set_up

    you must also add “dtparam=i2c_arm=on” (without quotes) to the end of /boot/config.txt and reboot

    The instructions on rayshobby wiki should probably be updated with the new setting for those that update to the 3.18 kernel.

     

    Once I added said entry to config.txt and rebooted, I now have RTC setup and can continue on. This is also likely to affect pi2 users since they will be at 3.18 from the get go.

     

    Hope it helps someone.

     

    Toonces

    #35616

    Dan in CA
    Participant

    Hi Toonces,

    This will definitely help a lot of users. The documentation on the Rayshobby wiki is getting a bit out of date. I will update it with your input.

    I am also starting to write some new documentation that can be accessed through the help button in the latest revs of the software or directly from:

    https://github.com/Dan-in-CA/OSPi/wiki

    Dan

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Fix for RTC clock not working after firmware update