This topic contains 18 replies, has 0 voices, and was last updated by  Ray 6 years ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #22420

    denny
    Member

    The login shows “6 May 2013 09:48:04 UTC-7:00”. It is 06:48 AM local time.
    I reset it to UTC-4 and rebooted. It now shows “6 May 2013 09:52:19 UTC-4:00”. The local time is 6:52 AM
    So no matter what I set for the UTC offset, it shows Eastern Standard Time.
    I did reboot each time.
    I have version 1.8.2.
    Any suggestions?

    #23608

    Ray
    Keymaster

    The user manual, and also the one-page instruction you received has this line:
    Setup Options:
    ***Once you are done, hold B3 again, until the controller restarts. Your changes are now saved and applied.

    If you don’t do this, the changes will not be saved.

    #23609

    Ray
    Keymaster

    Also, if the time doesn’t change, that means it’s not getting NTP sync signal. Check if you have a valid Internet connection, and make sure the NTP port (123) is not blocked by your router.

    #23610

    denny
    Member

    Hi Ray,

    Thank you for your quick responses. I really appreciate the help.

    So this problem just isn’t making sense to me. No matter what I do, the local time is UTC-4.

    In my first email I included the login I get when I power-on.
    “6 May 2013 09:48:04 UTC-7:00”. It is 06:48 AM local time.

    Doesn’t this show that the time has been saved as UTC-7:00 and the the local time is calculated wrong?
    So it seems like I saved it correctly. Is there something I need to do to make it ‘use’ the UTC offset that is shown?
    I have tried saving the time zone by using the B3 button on the device and also from the web interface using ‘reboot’.
    But nothing gives me the correct local time.

    Incidentally, I have saved it many times with different UTC offsets.
    Each time I power on, the UTC offset is correct, but the local time shown always incorrectly corresponds to UTC-4.

    So it seems that the problem is not saving the setup, but in calculating the local time from the UTC offset.
    Or it is not using the UTC offset that I save and is somehow stuck at UTC-4:00.

    I have tried changing the Location to different time zones and even leaving it blank but nothing changes the time to local time.

    Also the time does change so it is tracking.

    This is driving me crazy. Please help.
    I know it’s probably something dumb that I’m doing but I can’t seem to figure it out.

    Thanks for your patience.

    Here are my setting from the web page, maybe they will help.





    Here are my setting from the device (B3/LCD)
    === SetOptions ====
    Firmware version: 182
    Time Zone: -7:00 GMT
    NTP Sync: Yes
    Use DHCP: No
    Static.ip1: 192
    ip2: 168
    ip3: 0
    ip4: 21
    Gateway.ip1: 192
    ip2: 168
    ip3: 0
    ip4: 1
    HTTP port: 80
    Auto Reconnect: Yes
    Ext Boards: 1
    Sequential: Yes
    Station Delay: 10 sec
    Master Station: 0
    Use Rain Sensor: No
    Water Level(%): 100%
    Self Test time: 10 sec
    Ignore Password: No
    Reset All?: No

    #23611

    Ray
    Keymaster

    Did you look at my second reply above? I still suspect that maybe your controller is not getting NTP sync signal.

    One easy test to try is to take out the RTC battery (the CR1220 coin battery), wait for a minute, and then put the battery back and restart the controller. If it doesn’t get your current time, it means the controller is not getting NTP signal, that’s why it cannot update its time.

    #23612

    denny
    Member

    Hi Ray,

    I did look at the second suggestion you gave me and the time was changing. Maybe I misunderstood what you meant but it was always exactly 3 hours ahead of my local time.

    Anyway, I took out the battery and put it back in. The time is now 0:0 and the date is 1/1 so I guess it’s not getting time from the internet.

    I don’t have time right now to chase down this connection issue so I just want to run disconnected (NTP off)
    So how do I set the clock with NTP off? I walked throught all the steps on the device (using B3) and looked at the options on the web page but can’t see any way to do this.

    Thanks again,

    #23613

    Ray
    Keymaster

    I suggest that you figure out the NTP problem because otherwise the controller time will start to drift. Are you connecting the controller to your router directly through wired connection, or are you using a WiFi adapter?

    #23614

    denny
    Member

    It’s a wired connection.
    So there is no way to set the clock?

    #23615

    denny
    Member

    Now it seems to be resetting the RTC every time I reboot.
    Sat, 1 Jan 2000 00:00:08 UTC-7:00
    Any ideas?

    I don’t care about drift right now. I just need to get it working.

    #23616

    denny
    Member

    Does anybody know how to set the CLOCK? I don’t want to use NTP sync.
    My system is now completely unusable after following Ray’s suggestion of removing/replacing the battery.
    I keeps resetting to 0:00 every time I connect to the web server.

    #23617

    Ray
    Keymaster

    Unfortunately the firmware does not leave a way to manually set the clock (I didn’t think there would be a situation where you have Internet connection but no NTP sync). There are several ways you can set the clock (for example, plug it into another network which permits NTP sync, or upload an Arduino program that manually sets the clock. But in any case, I don’t recommend using the system without NTP, because the time will drift and after several months you may have to do the same trick again.

    #23618

    Ray
    Keymaster

    Hi Denny, just want to check back and see if the issue has been solved. Try to plug the controller to another network, and see if it can get the time successfully. If you cannot resolve the issue, I am happy to take it for return.

    #23619

    denny
    Member

    I reset it to the default settings and reconfigured everything.
    I rebooted all my Ethernet modem/switches.
    It seems to be working so far with the correct local time
    Thanks for your help.

    #23620

    Ray
    Keymaster

    OK, thanks for the update.

    #23621

    Jer
    Member

    I’m having similar issues but I think I may have tracked it down to a NTP refresh interval which may be lengthy interval. In other words, your clock doesn’t refresh every few seconds and likely updates every few minutes/hours since it’s not something that needs to be regularly adjusted once it’s set. When I change my time zone within the options the device time displays the proper offset (-7 in my case for Mountain Time US) but the previous time is still displayed. I left it and came back to it the next morning and the proper time was displayed (well, not proper since I had left it at -5 30 as I was experimenting) so my guess is that when you adjust the offset to NTP (only way to adjust the time) you have to wait until the device polls the NTP for time, applies your offset and adjusts local time. I have nothing to confirm this yet as I just set it to the proper (for me) offset and am waiting to see if my theory proves accurate. So, you may try setting your proper offset and giving it some time. I agree this isn’t the most attractive way to address this but if this is indeed the case it should set itself properly on the next refresh/poll. Perhaps Ray can chime in on what this interval is set at and if my guess is accurate. Adding an option to manually set the time or even using PC time (I have several items set to poll the PC for current time which I prefer since you have one less port open to the public, one less device polling an outside source that has potential to become a way into the network) would be a good way to give more flexibility for end users or possibly have it poll immediately after making a change to reflect the proper time instantly would resolve such issues.

    Just thinking out loud I guess and hoping someone with more knowledge on inner workings can chime in since I just received mine.

    #23622

    Ray
    Keymaster

    As described in the user manual, if you change the time zone, you should restart the controller to get the new time. This is because every time you restart the controller, it will perform an NTP sync immediately using the time zone in your settings. Now, if you don’t restart the controller, eventually it will still get the new time because the NTP sync is performed every 24 hours by default.

    #23623

    gregas
    Member

    I’m having similar issues. I’ve set it to GMT-8 and the time is still wrong. I’ve rebooted and power-cycled both open sprinkler and my gateway router. I’ve also verified that computers on the same network and see an NTP server. Not sure what to try next.

    #23624

    Ray
    Keymaster

    First, make sure on the homepage you see GMT-8. If not, that means your time zone change is not correctly saved.

    If that’s correct, then it might be that your router is blocking the NTP sync port 123 for some reason. OpenSprinkler uses the NTP server at 204.9.54.119 by default. If you have a linux machine, try to run the following command:
    nmap -p 123 -sT 204.9.54.119
    and see if it reports the port is open. If not, you may have to change corresponding settings on your router to see if you can unblock the port.

    #23625

    gregas
    Member

    Thanks, Ray. I just found the issue…bad gateway config. I’m not sure why I did not think of that. It works now.

    It looks like there is no daylight saving time adjustment…is that true? Not a big problem…just want to know.

    G

    #23626

    Ray
    Keymaster

    You are right, the firmware currently does not automatically detect DST yet, so you need to manually change the time zone. This shouldn’t be too hard to add, and I will try to get this feature included in future firmware update.

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.