OpenSprinkler Forums OpenSprinkler Unified Firmware Update to latest firmware doesn't work

This topic contains 12 replies, has 5 voices, and was last updated by  Ray 13 hours, 15 minutes ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #51389

    jeffhaas
    Participant

    I got the notification that new firmware was avaialable and followed the instructions…backed up my config, downloaded the firmware and then went to the update page. Selected the .bin file and entered the password. But got this error:

    Update failed. And then the device password box fills with dots. See attached screenshot.

    Any idea what to try?

    #51455

    Ray
    Keymaster

    First of all, make sure you’ve input device password correctly — it’s your OpenSprinkler’s device password (it’s opendoor if you have never changed it), not your WiFi password or anything else.

    Second, if update failed, give it another try. Sometimes the transfer may be interrupted due to WiFi signal issue etc. Try a few more times and see if it succeeds.

    #51460

    jeffhaas
    Participant

    I can connect to my OpenSprinkler and trigger one of the valves to run, edit the time, etc. so I’ve got the password correct. I connect from my desktop, my phone, my tablet, etc.

    Trying the transfer several more times gets the same result.

    Any other ideas?

    #51471

    nj7p
    Participant

    I am having a problem after the update. I manually updated the software from an SSH connection to the RasPi. The OpenSprinkler software is running as is Apache2. I cannot connect to the web page. It just times out.

    I did not save the settings, and the sprinklers are currently NOT running.

    Any Ideas?

    Bill

    #51485

    dman776
    Participant

    I have the same issue. Apache2 is running but the web server is not responding.
    [disregard. I saw the post to update Raspbian from Wheezy (SD image) to the latest Stretch and git clone from stratch]

    • This reply was modified 4 months, 2 weeks ago by  dman776.
    #51513

    Ray
    Keymaster

    For those who are having trouble with OSPi after firmware update, I will repeat the same message I said in other threads:

    This is most likely because your Raspbian is outdated, for example, if you’ve created your SD card from the pre-configured SD card image of OSPi (several years ago), that Raspbian is unfortunately outdated and does not support the IPv6 feature in the current firmware. The solution is to burn a new Raspbian system using the latest Raspbian image from RPi website, and then follow instructions here to install OpenSprinkler firmware:
    https://openthings.freshdesk.com/solution/articles/5000631599-installing-and-updating-the-unified-firmware

    If you don’t want to install new Raspbian, you can also roll back to an earlier firmware, but next time there is a firmware update you will encounter the same issue again, so it’s better to just solve it now.

    #53161

    Ian
    Participant

    Update 25th Nov: tried several times, update failed.
    ———————-
    Update 18th Nov: tried again, update failed.
    ———————-
    Tried to update firmware 7th Nov 18, several attempts tonight.
    Exact same result as OP; jeffhaas

    Opensprinkler Controller:
    App Version: 1.8.2
    Firmware: 2.1.7(1)
    Hardware Version: 3.0 – AC

    PC / Browser(s):
    macOS Mojave 10.14
    Chrome – Version 70.0.3538.77 (Official Build) (64-bit)
    Also Safari – Version 12.0 (14606.1.36.1.9)

    Source:
    https://github.com/OpenSprinkler/OpenSprinkler-Compiled-Firmware/tree/master/v3.0

    Typed in http://#.#.#.#/update failed,
    Clicked ‘bell’ notification and selected ‘update’, failed
    Used web interface to change password and log in again, just to be sure.
    Rebooted Controller.
    Tried http://#.#.#.#/update again, failed
    Typed this post and tried again, failed.
    Will try again tomorrow.

    Controller works a treat, still need to fine tune Zimmerman parameters, doesn’t water enough in cold weather (-4C -> 15C)
    Looking forward to using Evapotranspiration, local feed here:
    http://www.bom.gov.au/watl/eto/tables/nsw/canberra_airport/canberra_airport.html
    Would only need to download once a day at 1am.
    More data here: http://www.bom.gov.au/fwo/IDN60903/IDN60903.94926.json

    Hoping firmware update will fix a few glitches with log display failing when more than 2 days selected: https://github.com/OpenSprinkler/OpenSprinkler-Firmware/releases
    Log retrieval takes a long time or fails, hopefully new release increasing log space from 1MB to 3MB helps.
    Not sure why the log file on 7 stations would ever exceed 1MB over 7 days.
    Local time shown correct in app but red line in preview lags a couple of hours.

    Ian

    • This reply was modified 3 weeks, 4 days ago by  Ian.
    • This reply was modified 2 weeks, 4 days ago by  Ian.
    #53384

    Ray
    Keymaster

    @ian: just to make sure: when typing http://#.#.#.#/update you need to replace #.#.#.# by the actual IP address of your OpenSprinkler — #.#.#.# itself is not a valid IP address.

    #53408

    jeffhaas
    Participant

    Finally got around to working on this. It turns out I was trying to update the firmware from my desktop, which is connected via cable to the router (I can log into the controller, do all the typical settings, etc.) However, when I tried from my laptop using wifi, updating the firmware worked immediately.

    #53416

    Ian
    Participant

    Thanks for your response Ray, yes I did substitute the same numeric IP address that I successfully use to log in to the web interface.

    I see Jeffhaas in post #53408 had some success using his laptop over WIFI, but that implies he had the Opensprinkler in AP mode?

    My reading of the firmware update instructions I tried alternative #2. Update over WIFI.
    https://openthings.freshdesk.com/support/solutions/articles/5000381694-opensprinkler-firmware-update-guide

    I’ll try alternative #3. Update via AP mode, I wonder if that’s what Jeffhaas means “when I tried from my laptop using wifi”, Jeff might chime in here.

    One thing that would be nice with the updater web interface, if the diagnostic messages didn’t overwrite, but scrolled down the page so I could read all of them. They flash on and off too quickly to read.

    I will wait until the weekend to do this when I have more time, in case I have to reset to factory and reprogram my sprinkler settings manually.

    #53417

    jeffhaas
    Participant

    Hi Ian,

    I had the Opensprinkler in regular running mode. As I said, my desktop is connected directly into the router via Ethernet cable. I can log into the Opensprinkler, set up schedules, trigger manual run times, etc, as I sit at my desk and look out over the backyard. But trying to log into the updater didn’t work – I could get there but then it failed.

    Getting out a laptop and connecting via wifi to the same interface worked, quickly and easily.

    #53438

    Ian
    Participant

    Success!

    Thanks Jeff Hass, I had to do it on a WIFI connected laptop;

    Laptop -> WIFI router -> OpenSprinkler

    Logistically its better too, take the laptop to the controller, download the latest OS binary, download the latest controller config file, update the firmware, reconnect the controller to your WiFi, press controller button 1, reopen the web interface, change the password, reimport the config, all good to go. You could do it in 2 minutes.

    Thanks for Jeff and Ray’s help.

    #53486

    Ray
    Keymaster

    Ian and Jeff: ok, thanks for the update. I am puzzled by why it only works with WiFi connected laptop, really can’t think of a good explanation for it. But I will try it with a direct wired connected computer and see if I can reproduce it.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware Update to latest firmware doesn't work