OpenSprinkler Forums OpenSprinkler Unified Firmware Announcing the official OpenSprinkler Firmware 2.1.0 Reply To: Announcing the official OpenSprinkler Firmware 2.1.0



This is the first time I’ve updated my firmware.  I think I started with 2.05 or 2.06.  The issue I ran into was installing the driver as I’m running 2.1 hardware.  At first I attempted to install the driver (Windows 7 64-bit) with libusb_0.1.12.1 as indicated when you talked about Windows 8 installation.  This didn’t work so I thought I had to disable driver signature enforcement.  A quick google search and a reboot later and I tried to install the driver again.  Same result.  Then I uninstalled the driver and tried the other driver libusb_1.2.40 and it installed.  So I turned driver signature enforcement back on.

The point in this exercise is I don’t think driver signature enforcement is required for Windows 7 64-bit and it was never mentioned which driver should be installed.  Considering Windows 7 still holds the majority of OS share, I think it’s important directions should also cover Windows 7.  Your instructions seem to indicate Windows 7 and 8.x 64-bit should be lumped together.  Even if this was the case, the video instructions would indicate to install the first driver which did not work in my case.

A simple:  for Windows 7 users choose libusb_1.2.40 would have sufficed.  Even linking directly to the drivers from your webpage would be helpful rather than to the website where the drivers are located.  It doesn’t appear they update the drivers frequently as they are dated from 2011.

This is the first time I also added the uSD card with this major firmware update.  I think I read somewhere where it was advised to remove the uSD card before updating the firmware.  Is this a requirement?  I don’t want to have to remove the 4 screws unless I have to for future updates.

I also noticed that the static IP address didn’t keep when I restored my settings so I had to go in the advanced settings and turn off DHCP and manually set the IP and gateway again.  Has this been addressed in this firmware or is that by design?