OpenSprinkler Forums OpenSprinkler Mobile and Web App connecting to mobile app

  • This topic is empty.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #22832


    I recently received my opensprinkler with v 2.04
    My experience level average.
    No issues connecting locally everything appears to work fine. But after several hours, I cannot connect using the mobile app. I
    tried using my Verizon 4GLTE wired router but it just spins with no connect.
    I then tried it on my cisco router using cox broadband, same result.
    I suspect either a problem with my port forwarding or both Cox and Verizon dont allow access through port 80.
    I tried some other ports 443 and 5000 and they didnt work, but am getting beyond my experience level.
    At this point just want to connect, so not using static ip or dns.
    Any assistance or direction would be appreciated.



    It sounds like you know what your doing so I will jump right to it.

    Are you sure you are using the WAN IP address and not the local IP?

    When you say you tried other ports, did you change the port on the device as well? As a suggestion, you can use port triggering instead of forwarding to change the port (router translates one port on the WAN IP to the device).

    If you open your web browser, can you communicate with the OpenSprinkler directly? Example: http://wan_ip

    Doing some research based on your comment it appears you are correct about Cox blocking ports.

    I would just use port triggering if your router offers it. If not, change the port on the device and change the port forwarding to 5000 for example. In the mobile app though you will have to specify the port by adding a “:5000” (without the quotes).



    Thank You for your response,

    using WAN IP address ? / Yes I obtained by whatsmyip
    did I change ports on device/ yes then pressed b3 to recycle and verified new port number on the device
    can you communicate directly using WAN IP / No but can with Local IP:port

    results: I forwarded with port forwarding and port triggering and it worked this time. I then disabled the triggering and it still worked ???
    Was this a result of the triggering if it worked with the triggering disabled?

    But this success was on a router and network for testing only. knowing it worked, I then installed it back on my Verizon router /Verizon network which has no triggering option and it wont work.
    I used the IP:port in the app and set router to ip address start port 5000 end port 5000 protocal TCP
    I tried disabling firewall ?? but no change
    Verizon was unable to help me regarding their router.
    Any other ideas to offer me?



    So, your Verizon network may be blocking remote access. I did a google search and found this:

    Remote access is not possible on the 4G LTE network. The NAT firewall has been designed to hide public IP addresses and ports necessary to support that functionality.

    Please see the information and workarounds posted above.

    Q. “Will static ip fix or it is just not supported?”
    A. Yes. It will cost you a few hundred dollars for a static IP though.


    Can you access any other resource or is OpenSprinkler / mobile app the only thing giving you issues?

    Update: For the record, Ray and I are working to improve this process and remove port forwarding completely.



    Do any other resources work ? Yes eyez-on (alarm monitor), and teamviewer (remote desktop)
    Both of these have been used successfully for a week. I dont know how they work through the router? Regarding this being currently worked on for opensprinkler, a solution may be in how these 2 resources work.

    I have 3 of these 4gLTE routers ? Prior to purchase i inquired about the ability of port forwarding and they pointed out the routers port forwarding setup page. not clear what good port forwarding is if 2way comm is not possible.
    Will try a few other things based on you comments, including a visit to Verizon



    I know team viewer is smarter than a simple port forward and I assume the same for your other app. It seems to be an issue of using port forwarding or direct inbound connections.

    You could use a relay such as Yaler although I have no experience to assist there. Also with Team Viewer you could remote in and use a local browser (until a long term solution is reached).

    I will let you know if I think of anything else to help.



    I am not familiar with the 4GLTE router, but I won’t be surprised if itself is within a local network. What I mean is that the WAN IP shown on your router might not be accessible on the Internet — it’s not a public IP, but a local IP within Verizon’s network. The router’s WAN IP can be found on the router’s configuration / status page. Check if this is different from ‘whatsmyip’ result you get.



    can you connect on local network? (ie, Wifi on same network as OpenSprinkler)

    If your on the local network trying to connect to the external IP this will only work if your router supports NAT Loopback. If it does not do NAT loopback you will have to use the internal IP when at home and the external IP when connecting remotely… you will never connect to the external IP internally without this feature in your router.



    After some consideration I followed Rays suggestion and used remote desktop to control the opensprinkler.
    Unfortunately, Due to issues with my Verizon 4g LTE router, I will need to hold off on using the mobile app for now.
    But I am looking forward to using the opensprinkler. its a good product with good pricing. Was surprised when I received the
    new 16 station expander. To Ray, Salbahra and all contributors, You have done a Good Job !



    @Tomh sorry about the issues you had. I did a lot more research today and realized this is something Verizon does to get $500 (and probably as a minor protection to its clients).

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Mobile and Web App connecting to mobile app