OpenSprinkler Forums OpenSprinkler Mobile and Web App Connecting to OpenSprinkler when at home and away from home

This topic contains 6 replies, has 3 voices, and was last updated by  Samer 1 week, 4 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #46840

    Predrag
    Participant

    When I’m at home I can connect to OpenSprinkler without problems, using browser or Android App. All connections are directly to OpenSprinkler itself.
    Looking from the outside of my home network, I have nginx reverse proxy that accepts only HTTPS traffic, and OpenSprinkler access is protected at nginx level with HTTP auth (user name and password).

    When I use web browser away from home, I get first prompted by nginx to enter user name/password, and then redirected to OpenSprinkler that asks for its own password. All as expected. And desired.

    Unfortunately, using Android App, I can’t get through. I tried using DNS name, raw IP address, port and no port, checking SSL, checking Auth (I get to enter nginx user name and password, but I don’t know if they are triggered by nginx itself or by App in preparation for nginx asking for it). I pretty much tried any permutation of parameters. No matter what I get error message saying check your IP address and/or port. Needles to say, I checked them, and rechecked them. If they were wrong web browser wouldn’t work either.

    Is App even supposed to work in this scenario? Seems so, given the available parameters.

    App Version: 1.6.0
    Firmware: 2.1.7
    Hardware: 2.3 DC

    #46932

    JackTheDipper
    Participant

    Same problem here using nginx SSL proxy. Works in browser, but doesn’t work in app.

    SSL certificate is valid, but from letsencrypt, might this be the problem?

    App Version: 1.6.0
    Firmware: current master

    #47102

    JackTheDipper
    Participant

    Changed nginx configuration to serve the full certificate chain and now it’s working for me. Just strange that there were no certificate-related error messages by the app, that would have helped. 😉

    @predrag: Does this help you, either?

    #47105

    Predrag
    Participant

    Good suggestion. I will have to see how to do that in nginx. I will also have to switch to letsencrypt instead of doing self-signed.

    #47132

    JackTheDipper
    Participant

    @predrag: Just point to the fullchain.pem instead of the cert.pem. That’s it for nginx.

    Best

    #47133

    Predrag
    Participant

    You were right. Once certificate file contains full chain of authorities, OpenSprinkler App works. There should’ve been an error shown instead of just silently failing. But that may be an Android issue, not an App issue.
    While there, changed over all my proxied servers from self-signed to letsencrypt certificates. It was overdue. Thanks.

    #47150

    Samer
    Keymaster

    The app does not really know the rejection was due to SSL. The Cordova nature results in it just knowing the network failed (due to CORS and HTML5 security).

    Sent from my iPhone using Tapatalk

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Mobile and Web App Connecting to OpenSprinkler when at home and away from home