OpenSprinkler Forums Hardware Questions OpenSprinkler Connecting to Router in AP Mode

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #41659


    Here is my situation:

    – I have OpenSprinkler version 2.3-AC with the 2.1.6(1) firmware
    – Main Router in house – Netgear R8000
    – Secondary Router set to “AP Mode” in garage – NetgearWNDR4500
    – 2 Ethernet lines run to garage. #1 for the WNDR4500 as another WiFi signal and 4 port network switch. #2 is reserved for a future security system.
    – There is a 16 port network switch off of the R8000 for all Ethernet connections except the WNDR4500.
    – Port forwarding set on main router (since WNDR4500 is in AP Mode, no port forwarding capabilities are enabled)
    – I have a dynamic DNS name through linked my external IP address.

    Now the confusing part: If I plug a short Ethernet cable from the WNDR4500 in the garage to the OS controller, it works perfect from any hardwired or wifi mobile device as long as I’m still within my own LAN. The WNDR4500 is basically a network switch. If I turn off the wifi on my phone and use cell service (equivalent to accessing remotely) I cannot connect to the OS controller.

    If all I do is use the spare line #2 and attach that back to the main R8000 router/switch, all is well and I can connect remotely outside my LAN. The WNDR4500 should act as a wifi AP and a switch at the same time. OS attached to R8000 works remotely but OS attached to WNDR4500 in AP Mode does not.

    Why can’t I get to the OS controller remotely through the WNDR4500 but I can through the R8000? It works within my LAN. It acts like port forwarding works from the R8000 router but when trying to go through the WNDR4500 in AP Mode it doesn’t. I’m trying to avoid running another Ethernet line. I suppose I could use another dedicated network switch in the garage off of the spare line attached to the R8000. I haven’t tried that.



    I searched for hours before posting my original post. As soon as I post it I found the answer on my specific router. From NETGEAR support:

    Some routers allow you to configure the router as a wireless access point (AP) to extend your wireless range. It will then act as a simple wireless gateway and its sole purpose is to provide a wireless connection. Note that once a router becomes an access point, it will lose router functions such as port forwarding and DHCP server. This article applies to the following routers:


    I guess I’ll hook up a spare network switch and then split OS and security system off of it.

    I hope this helps others with the same issue.



    I am a bit confused by this part:
    “Secondary Router set to “AP Mode” in garage – NetgearWNDR4500”
    I assume your OpenSprinkler is connected to this secondary router. If it’s in AP mode, then that means any device connected to it is on a different local network than your main router. So you will need to set up port forwarding on your secondary router (NetgearWNDR4500) in order for any device connected to the main router to reach OpenSprinkler. On the other hand, if your secondary router is a switch, then you probably don’t need to do so.



    So the secondary router (WNDR4500) is really the access point in my garage connected to the primary router (R8000). It’s an extension of the primary router. I thought the Ethernet ports would act like a generic switch but it doesn’t. The setup on the WNDR4500 has the port forwarding and many other settings like DHCP disabled. The 2nd post above documented from Netgear that port forwarding is disabled when it’s in AP mode.

    I proved this tonight by plugging in a old 4 port 100Mb switch off the spare line and it port forwarded just fine.

    Maybe other router brands will allow port forwarding through them while in AP mode but this one won’t.



    bkastel, not sure if this helps you, but your problem description actually matches an issue I had when first installing my OSPi. I believe the symptoms would probably apply to a lot of internal vs. external network issues.

    If I’m inside my WAN, I access my OSPi via the internal IP (192.168…) given by the router’s DHCP (static routes, BTW). Outside my WAN, say, on cellular or whatever else, I use the port forwarding IP. The port-forwarded IP does not work on my home WiFi, nor does the internal work from outside (duh). My solution so far has been to create two controller instances in the mobile app–one for @Home, and the other for remote, both using the respective IP addresses that work in each case.

    Again, not sure if this helps, but I posted just in case it might.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Connecting to Router in AP Mode